Telefonino.net network
 
| HOMEPAGE | INDICE FORUM | REGOLAMENTO | ::. NEI PREFERITI .:: | RSS Forum | RSS News | NEWS web | NEWS software |
| PUBBLICITA' | | ARTICOLI | WIN XP | VISTA | WIN 7 | REGISTRI | SOFTWARE | MANUALI | RECENSIONI | LINUX | HUMOR | HARDWARE | DOWNLOAD | | CERCA nel FORUM » |

Torna indietro   WinTricks Forum > Sistemi Operativi > Linux e altri Sistemi Operativi

Notices

Rispondi
 
Strumenti discussione
Vecchio 26-10-2007, 12.55.25   #1
agimar
Hero Member
 
Registrato: 05-08-2000
Loc.: Villar Perosa italy
Messaggi: 552
agimar promette bene
[LINUX] errore lilo 99

Buon giorno a tutti,
un amico vorrebbe linux sul suo pc, dopo che ha visto che io lo uso intensamente (ho installato Mandriva 2007).
15 giorni fa mi porta il suo PC, installo Paragon Partition e creo una partizione linux extension 3 ed una di swap, nell'ultima parte dell'HD. Installo linux e indico nel Floppy la destinazione del lilo boot. Terminate le operazioni di installazione riavvio, ma il systema non parte da floppy e mi restituisce l'errore L 99 (99 99 ...).
Penso che sia il floppy, lo sostituisco, reinstallo linux ed il lilo boot sul floppy nuovo: stesso errore, allora installo (sempre su floppy) GRUB che NON parte e mi da errore: GRUB 18.
Allora decido di installare il lilo sull' mbr del disco C: Prima con lilo e poi con grub. Stesso errore.
Allora riformatto la partizione di linux e decido di installare SUSE, l'installazione procede bene e termina, come sempre, con la fatidica frase: Suse correttamente installato, togli il DVD e riavvia.
Stesso identico errore di prima sia con LILO che con Grub e sia con floppy, che con MBR.
Faccio partire il PC da CD con una versione live di Mandriva 2008 ONE, parte regolarmente e provo qualche applicazione. Tutto funziona bene (con le limitazioni che derivano dalla versione live!)
Un opzione mi dice che se voglio installare Mandriva One sull'hd lo posso fare. Faccio partire l'installazione e installo ONE nella partizione linux creata precedentemente con Paragon Partition.
Tutto regolare... mi chiede dove desidero configurare il boot. Faccio
tre tentativi, sul floppy, sull'MBR e sulla partizione in cui è installato
linux (hdb8), ma NULLA! Medesimo errore. Linux è installato, ma non so farlo
partire. Con un'utility dal nome explore2fs-1.08beta9.exe da ambiente WinXP sono andato a visualizzare il contenuto di Linux ed ho estratto il file LILO.conf in /etc/ che riporto qui sotto (qualora potesse servire a risolvere il problema):

# File generated by DrakX/drakboot
# WARNING: do not forget to run lilo after modifying this file

default="linux"
boot=/dev/hda
map=/boot/map
keytable=/boot/it-latin1.klt
prompt
nowarn
timeout=100
message=/boot/message
menu-scheme=wb:bw:wb:bw
image=/boot/vmlinuz
label="linux"
root=/dev/hda8
initrd=/boot/initrd.img
append="devfs=nomount acpi=ht resume=/dev/hda9 splash=silent"
vga=788
read-only
image=/boot/vmlinuz
label="linux-nonfb"
root=/dev/hda8
initrd=/boot/initrd.img
append="devfs=nomount acpi=ht resume=/dev/hda9 splash=silent"
read-only
other=/dev/hda1
label="windows"
table=/dev/hda
image=/boot/vmlinuz
label="failsafe"
root=/dev/hda8
initrd=/boot/initrd.img
append="failsafe acpi=ht resume=/dev/hda9 splash=silent devfs=nomount"
read-only

In sostanza, la mia domanda è:
come posso installare lilo (o grub) su un floppy in modo che all'avvio mi possa far partire linux?

Grazie.
agimar
agimar non è collegato   Rispondi citando
Vecchio 26-10-2007, 21.19.24   #2
UG0_BOSS
Young Promise
 
Registrato: 04-02-2006
Messaggi: 2.114
UG0_BOSS promette bene
Girando qua e là su internet (link) pare che un modo per risolvere la faccenda sia di creare una partizione di boot (da montare in /boot) all'inizio del disco: ci installi GRUB o LiLo e conterrà quindi kernel, initrd e la configurazione del boot loader.
UG0_BOSS non è collegato   Rispondi citando
Vecchio 26-10-2007, 23.45.44   #3
agimar
Hero Member
 
Registrato: 05-08-2000
Loc.: Villar Perosa italy
Messaggi: 552
agimar promette bene
Grazie Ugo_Boss, il tuo link è stato molto utile... Ho cercato tanto in internet, ma quel 3D indicato da te non l'avevo letto. Non mi risolve il problema, ma mi orienta verso il BIOS, a cui avevo già pensato anche io. Io non posso creare una partizione all'inizio dell'HD perchè lì c'è Windows e non mi permetto di toccare visto che non è il mio PC. Potrei mettere però un secondo HD ed installare linux lì... Ora ci penso, ma quello che mi fa strano è neanche con LILO il mio sistema parta, mentre quello del "nuovo utente" si avvia con LILO e non con GRUB. Grazie ancora!
agimar
agimar non è collegato   Rispondi citando
Vecchio 30-10-2007, 00.45.48   #4
agimar
Hero Member
 
Registrato: 05-08-2000
Loc.: Villar Perosa italy
Messaggi: 552
agimar promette bene
Caro Ugo_Boss, ho risolto il problema grazie al tuo intervento e al link che mi hai indicato. Era un broblema di Bios e di dimensione dell'HDisk (160 giga). Ho risolto così: ho messo un HD da 20 giga sul secondario master e lì ho installato linux. ha funzionato subito sia il LILO che il GRUB, sia da boot da floppy che da HD.
Quindi... Grazie!
agimar
agimar non è collegato   Rispondi citando
Rispondi


Utenti attualmente attivi che stanno leggendo questa discussione: 1 (0 utenti e 1 ospiti)
 
Strumenti discussione

Regole di scrittura
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is ON
Gli smilies sono ON
[IMG] è ON
Il codice HTML è OFF

Vai al forum

Discussioni simili
Discussione Autore discussione Forum Risposte Ultimo messaggio
[LINUX] Disinstallazione Lilo boyashi Linux e altri Sistemi Operativi 4 29-03-2006 20.39.36
Errore I/O nel settore dell HD. Elenco Software per recuperare i dati su HD. anno Hardware e Overclock 10 04-03-2006 10.31.00
[LINUX] errore filesystem nana_d Linux e altri Sistemi Operativi 2 20-11-2004 12.02.53
[Linux] problemino con LiLo... ha Cancellato la MBR! [OK] Marco Redaelli Linux e altri Sistemi Operativi 5 05-10-2004 22.25.30
beep al boot maefe Hardware e Overclock 6 08-11-2003 12.06.56

Orario GMT +2. Ora sono le: 06.36.10.


E' vietata la riproduzione, anche solo in parte, di contenuti e grafica.
Copyright © 1999-2017 Edizioni Master S.p.A. p.iva: 02105820787 • Tutti i diritti sono riservati
L'editore NON si assume nessuna responsabilità dei contenuti pubblicati sul forum in quanto redatti direttamente dagli utenti.
Questi ultimi sono responsabili dei contenuti da loro riportati nelle discussioni del forum
Powered by vBulletin - 2010 Copyright © Jelsoft Enterprises Limited.