Telefonino.net network
 
| HOMEPAGE | INDICE FORUM | REGOLAMENTO | ::. NEI PREFERITI .:: | RSS Forum | RSS News | NEWS web | NEWS software |
| PUBBLICITA' | | ARTICOLI | WIN XP | VISTA | WIN 7 | REGISTRI | SOFTWARE | MANUALI | RECENSIONI | LINUX | HUMOR | HARDWARE | DOWNLOAD | | CERCA nel FORUM » |

Torna indietro   WinTricks Forum > Software > Programmazione

Notices

Rispondi
 
Strumenti discussione
Vecchio 05-07-2007, 03.40.26   #1
UG0_BOSS
Young Promise
 
Registrato: 04-02-2006
Messaggi: 2.114
UG0_BOSS promette bene
[HTML] Definire la codifica della pagina negli header

Ciao a tutti

Per realizzare il mio sito personale ho sempre utilizzato la codifica unicode UTF-8, mettendo in tutti i file il seguente header:
Codice:
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
in modo che venisse riconosciuta la codifica in automatico dai browser.

Oggi ho notato, però, che le parole accentate non vengono più lette correttamente in automatico, ma solo impostando il browser su UTF-8.
In pratica l'header non viene più letto correttamente però è presente in tutte le pagine e non ho fatto modifiche recentemente alla parte <HEAD>.

Sapete cosa potrebbe essere? In alternetiva sapete consigliarmi un altro modo per definire la codifica della pagina? Thanks
UG0_BOSS non è collegato   Rispondi citando
Vecchio 07-07-2007, 13.59.25   #2
quipo.it
WT Assistant
 
L'avatar di quipo.it
 
Registrato: 19-12-2000
Loc.: Cambiano (Torino)
Messaggi: 591
quipo.it promette bene
a volte serve anche che il web server mandi l'header giusto...

Se hai apache, puoi mettere questa direttiva nel file .htaccess:

ForceType 'text/html; charset=utf-8'
___________________________________

There are 10 kinds of people in this world,
those who can read binary and those who can't.

Care to say "thank you"?
quipo.it non è collegato   Rispondi citando
Vecchio 07-07-2007, 15.14.40   #3
UG0_BOSS
Young Promise
 
Registrato: 04-02-2006
Messaggi: 2.114
UG0_BOSS promette bene
Quota:
Inviato da quipo.it
a volte serve anche che il web server mandi l'header giusto...

Se hai apache, puoi mettere questa direttiva nel file .htaccess:

ForceType 'text/html; charset=utf-8'
Uhm a questo non avevo pensato

Il sito però è hostato su un server non mio perciò non posso controllare il webserver... proverò a chiedere ai gestori
UG0_BOSS non è collegato   Rispondi citando
Vecchio 07-07-2007, 15.49.04   #4
quipo.it
WT Assistant
 
L'avatar di quipo.it
 
Registrato: 19-12-2000
Loc.: Cambiano (Torino)
Messaggi: 591
quipo.it promette bene
non è necessario, basta che piazzi un file .htaccess nella root del sito (o almeno nella directory che contiene i files html)
___________________________________

There are 10 kinds of people in this world,
those who can read binary and those who can't.

Care to say "thank you"?
quipo.it non è collegato   Rispondi citando
Vecchio 07-07-2007, 15.58.21   #5
UG0_BOSS
Young Promise
 
Registrato: 04-02-2006
Messaggi: 2.114
UG0_BOSS promette bene
Quota:
Inviato da quipo.it
non è necessario, basta che piazzi un file .htaccess nella root del sito (o almeno nella directory che contiene i files html)
Perfetto, ha funzionato... grazie mille
UG0_BOSS non è collegato   Rispondi citando
Vecchio 08-07-2007, 14.08.47   #6
UG0_BOSS
Young Promise
 
Registrato: 04-02-2006
Messaggi: 2.114
UG0_BOSS promette bene
Ho un ulteriore problema...

Con quella riga nel file .htaccess non funziona il PHP lo script è giusto (su un altra macchina funge) però non viene neanche interpretato dal php.
Ho provato a non specificare text/html (ForceType "charset=utf-8") però in questo modo non funziona nè il PHP e nemmeno i CSS scritti nella pagina

Cosa potrebbe essere?
UG0_BOSS non è collegato   Rispondi citando
Vecchio 11-07-2007, 17.24.19   #7
quipo.it
WT Assistant
 
L'avatar di quipo.it
 
Registrato: 19-12-2000
Loc.: Cambiano (Torino)
Messaggi: 591
quipo.it promette bene
Prova a sostituire la direttiva con questa:

Codice:
AddDefaultCharset UTF-8
ForceType in effetti cambia anche il Content Type.
___________________________________

There are 10 kinds of people in this world,
those who can read binary and those who can't.

Care to say "thank you"?
quipo.it non è collegato   Rispondi citando
Vecchio 11-07-2007, 22.01.06   #8
UG0_BOSS
Young Promise
 
Registrato: 04-02-2006
Messaggi: 2.114
UG0_BOSS promette bene
Ok ora funziona tutto correttamente... ancora grazie
UG0_BOSS non è collegato   Rispondi citando
Rispondi


Utenti attualmente attivi che stanno leggendo questa discussione: 1 (0 utenti e 1 ospiti)
 
Strumenti discussione

Regole di scrittura
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is ON
Gli smilies sono ON
[IMG] è ON
Il codice HTML è OFF

Vai al forum

Discussioni simili
Discussione Autore discussione Forum Risposte Ultimo messaggio
Referendum 12-13 giugno Gigi75 Chiacchiere in libertà 937 09-11-2008 12.53.07
Errore nello script della pagina tex56 Internet e Reti locali 3 30-11-2005 19.49.47
Esecuzione di un povero cristo Skipper Chiacchiere in libertà 193 22-09-2004 06.52.32
Censurateli tutti allora! Non solo chi vi fa comodo :mad: davlak Chiacchiere in libertà 52 20-05-2004 12.26.15
IE6sp1 su W2kSP4: Non va in Offline crib Windows 9x/Me/NT4/2000 1 25-11-2003 18.22.40

Orario GMT +2. Ora sono le: 16.48.25.


E' vietata la riproduzione, anche solo in parte, di contenuti e grafica.
Copyright © 1999-2017 Edizioni Master S.p.A. p.iva: 02105820787 • Tutti i diritti sono riservati
L'editore NON si assume nessuna responsabilità dei contenuti pubblicati sul forum in quanto redatti direttamente dagli utenti.
Questi ultimi sono responsabili dei contenuti da loro riportati nelle discussioni del forum
Powered by vBulletin - 2010 Copyright © Jelsoft Enterprises Limited.