Telefonino.net network
 
| HOMEPAGE | INDICE FORUM | REGOLAMENTO | ::. NEI PREFERITI .:: | RSS Forum | RSS News | NEWS web | NEWS software |
| PUBBLICITA' | | ARTICOLI | WIN XP | VISTA | WIN 7 | REGISTRI | SOFTWARE | MANUALI | RECENSIONI | LINUX | HUMOR | HARDWARE | DOWNLOAD | | CERCA nel FORUM » |

Torna indietro   WinTricks Forum > Sistemi Operativi > Linux e altri Sistemi Operativi

Notices

Rispondi
 
Strumenti discussione
Vecchio 19-06-2004, 22.09.21   #1
monossido
Senior Member
 
Registrato: 12-05-2002
Loc.: padova
Messaggi: 407
monossido promette bene
matrox g400 su debian woody

ho installato mgapdesk xserver-xfree86 ...configurato ma l'x server nn parte...allego il log...cmq in particolare:


(WW) Warning, couldn't open module mga_hal
(II) UnloadModule: "mga_hal"
(EE) MGA: Failed to load module "mga_hal" (module does not exist, 0)
(--) MGA(0): Chipset: "mgag400"
(==) MGA(0): Using AGP 1x mode
(**) MGA(0): Using framebuffer device
(II) Loading sub module "fbdevhw"
(II) LoadModule: "fbdevhw"
(II) Loading /usr/X11R6/lib/modules/linux/libfbdevhw.a
(II) Module fbdevhw: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 0.0.2
ABI class: XFree86 Video Driver, version 0.4
(II) UnloadModule: "mga"
(II) UnloadModule: "fbdevhw"
(II) Unloading /usr/X11R6/lib/modules/linux/libfbdevhw.a
(II) UnloadModule: "vgahw"
(II) Unloading /usr/X11R6/lib/modules/libvgahw.a
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
___________________________________

why do you drink and drive...when you can smoke and fly???
monossido non  collegato   Rispondi citando
Vecchio 19-06-2004, 22.11.33   #2
monossido
Senior Member
 
Registrato: 12-05-2002
Loc.: padova
Messaggi: 407
monossido promette bene
da quello che ho capito nn gli va bene la configurazione ed ecco XF86Config-4:
### BEGIN DEBCONF SECTION
# XF86Config-4 (XFree86 server configuration file) generated by dexconf, the
# Debian X Configuration tool, using values from the debconf database.
#
# Edit this file with caution, and see the XF86Config-4 manual page.
# (Type "man XF86Config-4" at the shell prompt.)
#
# If you want your changes to this file preserved by dexconf, only make changes
# before the "### BEGIN DEBCONF SECTION" line above, and/or after the
# "### END DEBCONF SECTION" line below.
#
# To change things within the debconf section, run the command:
# dpkg-reconfigure xserver-xfree86
# as root. Also see "How do I add custom sections to a dexconf-generated
# XF86Config or XF86Config-4 file?" in /usr/share/doc/xfree86-common/FAQ.gz.

Section "Files"
FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
Load "GLcore"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "pex5"
Load "record"
Load "speedo"
Load "type1"
Load "vbe"
Load "xie"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/psaux"
Option "Protocol" "PS/2"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Generic Mouse"
Driver "mouse"
Option "SendCoreEvents" "true"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "matrox g400"
Driver "mga"
Option "UseFBDev" "true"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
HorizSync 30-50
VertRefresh 50-100
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "matrox g400"
Monitor "Generic Monitor"
DefaultDepth 16
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection
Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Generic Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection

### END DEBCONF SECTION
___________________________________

why do you drink and drive...when you can smoke and fly???
monossido non  collegato   Rispondi citando
Vecchio 20-06-2004, 00.40.18   #3
ANDY CAPS
Hero Member
 
L'avatar di ANDY CAPS
 
Registrato: 15-09-2002
Loc.: siena
Messaggi: 1.101
ANDY CAPS promette bene
prova a caricare agp con modconf dai moduli char altrimenti metti i driver vesa momentaneamente
il moduelo mga un po rognosetto se non aggiorni kernel ed xfree
altrimenti prova ad installare i file di glu


non ricordo i file sulla woody

apt-cache search glu | less

per vedere l'elenco dei file


guarda se hai disponibili

gmgaclock - Matrox G400 graphics card overclocking tool
mga-vid-common - Module aliases and test program for /dev/mga_vid
mga-vid-source - Kernel driver for the back-end scaler on Matrox cards (source)
mgapdesk - X configuration tool for Matrox video card.

una volta installati po la doc la trovi in /usr/share/doc
___________________________________

.................AND.................
ANDY CAPS non  collegato   Rispondi citando
Vecchio 20-06-2004, 15.51.36   #4
monossido
Senior Member
 
Registrato: 12-05-2002
Loc.: padova
Messaggi: 407
monossido promette bene
mga-vid-common mi ha detto di creare mga_vid (o simile) in /dev con mknod e altri 2 comandi ok...i source invece nel readme dice che devo andare nei source del kernel e fare make-kpkg modules_install ma mi dice comando nn valido...

ho kernel 2.6.6...adesso provo con agp e vesa ma mi pareva nn andasse lo stesso....le glu sono tanttissime
___________________________________

why do you drink and drive...when you can smoke and fly???
monossido non  collegato   Rispondi citando
Vecchio 20-06-2004, 16.30.35   #5
ANDY CAPS
Hero Member
 
L'avatar di ANDY CAPS
 
Registrato: 15-09-2002
Loc.: siena
Messaggi: 1.101
ANDY CAPS promette bene
se hai il kernel 2.6.6 dovrebbe andare tranquillamente basta caricare i moduli corretti dai charatter device tipo l'agp della tua scheda ed i moduli della matrox oltre ai driver dal menu graphics

con il kernel 2.6 i driver della matrox che hai scaricato probabilmenta e non andranno
se vuoi provare devi installare kernel-package con apt

poi dare make-kpkg modules_install

mi sembrava fosse
make-kpkg modules_image e poi si dovesse installare con dpkg -i il deb che si crea in /usr/src

io ho la sid ed i file sono diversi
guarda se ti installa

apt-get install libglut3 libglut3-dev libglui2c102 xlibmesa-dev xlibmesa-glu
___________________________________

.................AND.................
ANDY CAPS non  collegato   Rispondi citando
Vecchio 20-06-2004, 18.40.40   #6
monossido
Senior Member
 
Registrato: 12-05-2002
Loc.: padova
Messaggi: 407
monossido promette bene
mmmm...quando tento di caricare mga mi dice che nn trova agpgart...xr caricato!!!!!!!!!!!!
___________________________________

why do you drink and drive...when you can smoke and fly???
monossido non  collegato   Rispondi citando
Vecchio 20-06-2004, 19.07.39   #7
ANDY CAPS
Hero Member
 
L'avatar di ANDY CAPS
 
Registrato: 15-09-2002
Loc.: siena
Messaggi: 1.101
ANDY CAPS promette bene
guarda se hai caricato il mosulo specifico per la tua scheda madre


Character devices><

M> /dev/agpgart (AGP Support) │ │
│ │ < > ALI chipset support │ │
│ │ < > ATI chipset support │ │
│ │ < > AMD Irongate, 761, and 762 chipset support │ │
│ │ < > AMD Opteron/Athlon64 on-CPU GART support │ │
│ │ < > Intel 440LX/BX/GX, I8xx and E7x05 chipset support │ │
│ │ < > Intel i865 chipset support │ │
│ │ < > NVIDIA nForce/nForce2 chipset support │ │
│ │ <M> SiS chipset support │ │
│ │ < > Serverworks LE/HE chipset support │ │
│ │ <M> VIA chipset support │ │
│ │ < > Transmeta Efficeon support │ │
│ │[*] Direct Rendering Manager (XFree86 4.1.0 and higher DRI support)


questi che poi devi scrivere in /etc/modules che scheda madre hai ?
___________________________________

.................AND.................
ANDY CAPS non  collegato   Rispondi citando
Vecchio 21-06-2004, 00.33.15   #8
monossido
Senior Member
 
Registrato: 12-05-2002
Loc.: padova
Messaggi: 407
monossido promette bene
nn mi andava + l'adsl quindi senza aiuti (lol) ho optato x una soluzione drastica ho reinstallato e rimesso kernel 2.6 il modulo mga nn lo carica lo stesso...ma quelle cose dove le trovo???


e poi adesso quando avvio X nn trova neanke il mouse...lui va a cercarselo in /dev/psaux...e in effetti psaux esiste!!
___________________________________

why do you drink and drive...when you can smoke and fly???
monossido non  collegato   Rispondi citando
Vecchio 21-06-2004, 02.18.23   #9
ANDY CAPS
Hero Member
 
L'avatar di ANDY CAPS
 
Registrato: 15-09-2002
Loc.: siena
Messaggi: 1.101
ANDY CAPS promette bene
quelli sono i moduli dell'agp

li trovi dal make menuconfig compilando il kernel
nel gruppo charatters device
riconfigura con

dpkg-reconfigure xserver-xfree86

e metti i vesa deve partire per forza

con modconf metti i moduli delle periferiche di input > mouse
poi scegli come protocollo IMps

devi mettere l'agp della tua mobo

guarda in /lib/modules/2.6.*/kernel/drivers/char/agp
cosa hai e carica con modprobe quello della tua mobo se modconf non va

senza quello difficile farla partire
___________________________________

.................AND.................
ANDY CAPS non  collegato   Rispondi citando
Vecchio 21-06-2004, 02.42.17   #10
monossido
Senior Member
 
Registrato: 12-05-2002
Loc.: padova
Messaggi: 407
monossido promette bene
ok ho fatto caricare intel-agp e mga lo carica ho messo vesa ma il mouse ankora niente...ho caricato psmouse dentro a input... un semplice mouse ps2
___________________________________

why do you drink and drive...when you can smoke and fly???
monossido non  collegato   Rispondi citando
Vecchio 21-06-2004, 03.00.58   #11
ANDY CAPS
Hero Member
 
L'avatar di ANDY CAPS
 
Registrato: 15-09-2002
Loc.: siena
Messaggi: 1.101
ANDY CAPS promette bene
non si che kernel hai della serie 2,6
per trovarsi bene le periferiche di input dovrebbero essere messe come statiche e non come modulo

se fosse uno dei primi 2.6 prova a dare un modprobe mice
modprobe psmouse
modprobe input

psmouse scrivilo in /etc/modules poi ritenta dpkg-reconfigure xserver-xfree86

prova anche il logitech
___________________________________

.................AND.................
ANDY CAPS non  collegato   Rispondi citando
Vecchio 21-06-2004, 13.20.07   #12
monossido
Senior Member
 
Registrato: 12-05-2002
Loc.: padova
Messaggi: 407
monossido promette bene
ho messo mousedev e va...con vesa...provo a mettere mga...ma cosa cambia?
___________________________________

why do you drink and drive...when you can smoke and fly???
monossido non  collegato   Rispondi citando
Vecchio 21-06-2004, 13.23.41   #13
monossido
Senior Member
 
Registrato: 12-05-2002
Loc.: padova
Messaggi: 407
monossido promette bene
va anke mga cosa cambia?
___________________________________

why do you drink and drive...when you can smoke and fly???
monossido non  collegato   Rispondi citando
Vecchio 21-06-2004, 14.18.34   #14
ANDY CAPS
Hero Member
 
L'avatar di ANDY CAPS
 
Registrato: 15-09-2002
Loc.: siena
Messaggi: 1.101
ANDY CAPS promette bene
con l'mga pui avere anche l'accelerazione grafica installado mgapdesk ed avviamdolo da consolle se hai abilitato i moduli corretti dal menu graphics del kernel
___________________________________

.................AND.................
ANDY CAPS non  collegato   Rispondi citando
Rispondi


Utenti attualmente attivi che stanno leggendo questa discussione: 1 (0 utenti e 1 ospiti)
 
Strumenti discussione

Regole di scrittura
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is ON
Gli smilies sono ON
Il codice HTML OFF

Vai al forum

Discussioni simili
Discussione Autore discussione Forum Risposte Ultimo messaggio
[DEBIAN] WOODY - Installazione hamachi , problema con installazione tun driver gutguy Linux e altri Sistemi Operativi 4 14-09-2005 16.27.46
[DEBIAN] woody - aiuto installazione darkblack Linux e altri Sistemi Operativi 5 12-01-2005 09.19.57
[DEBIAN] Debian Sarge nana_d Linux e altri Sistemi Operativi 3 17-04-2004 20.55.01
Matrox G400 Codec Wanted: AIUTATEMI !!!! mec66 Hardware e Overclock 1 14-09-2003 20.10.21
Matrox G400 Codec mec66 Hardware e Overclock 0 14-09-2003 19.29.11

Orario GMT +2. Ora sono le: 05.32.17.


E' vietata la riproduzione, anche solo in parte, di contenuti e grafica.
Copyright 1999-2017 Edizioni Master S.p.A. p.iva: 02105820787 Tutti i diritti sono riservati
L'editore NON si assume nessuna responsabilità dei contenuti pubblicati sul forum in quanto redatti direttamente dagli utenti.
Questi ultimi sono responsabili dei contenuti da loro riportati nelle discussioni del forum
Powered by vBulletin - 2010 Copyright Jelsoft Enterprises Limited.