Telefonino.net network
 
| HOMEPAGE | INDICE FORUM | REGOLAMENTO | ::. NEI PREFERITI .:: | RSS Forum | RSS News | NEWS web | NEWS software |
| PUBBLICITA' | | ARTICOLI | WIN XP | VISTA | WIN 7 | REGISTRI | SOFTWARE | MANUALI | RECENSIONI | LINUX | HUMOR | HARDWARE | DOWNLOAD | | CERCA nel FORUM » |

Torna indietro   WinTricks Forum > Software > Programmazione

Notices

Rispondi
 
Strumenti discussione
Vecchio 19-11-2013, 00.51.10   #1
Thelastone
Junior Member
 
Registrato: 17-11-2008
Loc.: Bordighera
Messaggi: 66
Thelastone promette bene
Problemi con Visual C++ 2005

Ciao a tutti.
Non penso che questa sia la sezione giusta, ma è l'unica nella quale la ricerca mi ha indicato che qui si nomini, anche se per altro motivo, il Visual c++.

Prego i Mod. di spostare il 3d se necessario.

Devo fare dei DVD coi video di mio nipote e nei giorni scorsi ho cercato di installare i trial di Corel, di Pinnacle e di CyberLink, nessuno andato a buon fine per la stessa ragione, questa:

"Il processo non può proseguire perché l'installazione (Microsoft Visual C++ 2005 Service Pack 1 Redistributable Package ATL Security Update (x86)) non è riuscita. Contattare il supporto tecnico Microsoft per assistenza. L'installazione verrà annullata".

Questo nonostante sul PC siano già installate sette versioni di Visual c++, cinque del 2008 e due del 2010, più un Visual Studio 2005, che non so a che servano...

Il supporto Microsoft è inesistente: l'unica cosa che ho ottenuto dopo molti tentativi è di sapere che siccome il mio OS (Windows 7 64 home premium) era preinstallato sul PC, il supporto sarebbe stato a pagamento (a partire da 72 euro...).

Ho scaricato e cercato di installare quattro diverse versioni di Visual C++ 2005 eccetera, ottenendo solo, per tutte, questo: errore 1935.

"Errore 1935. Errore durante l'installazione dell'assembly.
Microsoft.VC80.Open MP type="win32", version="8.0.50727.762", publicKeyToken="1fc8b3b9a1e18e3b", processor architecture="x86".
Per ulteriori informazioni, vedere guida e supporto tecnico.

Almeno uno dei software sunnominati mi serve. Che cosa posso fare?

Grazie a tutti
Thelastone non è collegato   Rispondi citando
Vecchio 19-11-2013, 01.11.01   #2
AMIGA
Gold Member
Top Poster
 
L'avatar di AMIGA
 
Registrato: 06-07-2006
Loc.: Brindisi
Messaggi: 10.106
AMIGA è un gioiello raroAMIGA è un gioiello raroAMIGA è un gioiello raro
Rif: Problemi con Visual C++ 2005

Già letto questo
___________________________________

Dove l'ho sentita ? www.plagimusicali.net

English Amiga Board Amiganews.it AfA One AROS x86 AROS 68k
AMIGA non è collegato   Rispondi citando
Vecchio 19-11-2013, 12.00.37   #3
Thelastone
Junior Member
 
Registrato: 17-11-2008
Loc.: Bordighera
Messaggi: 66
Thelastone promette bene
Rif: Problemi con Visual C++ 2005

Amiga, sei forte! (D'altra parte, uno come me che giocava col Commodore 64 lo sapeva già...)
Dall'altra punta dell'Italia un GRAZIE grosso quanto lo schermo!
Thelastone non è collegato   Rispondi citando
Vecchio 19-11-2013, 14.49.17   #4
AMIGA
Gold Member
Top Poster
 
L'avatar di AMIGA
 
Registrato: 06-07-2006
Loc.: Brindisi
Messaggi: 10.106
AMIGA è un gioiello raroAMIGA è un gioiello raroAMIGA è un gioiello raro
Rif: Problemi con Visual C++ 2005

Grazie Thelastone, mi fà piacere che il mio intervento ti sia stato in qualche modo d'aiuto.
___________________________________

Dove l'ho sentita ? www.plagimusicali.net

English Amiga Board Amiganews.it AfA One AROS x86 AROS 68k
AMIGA non è collegato   Rispondi citando
Vecchio 19-11-2013, 19.15.48   #5
Thelastone
Junior Member
 
Registrato: 17-11-2008
Loc.: Bordighera
Messaggi: 66
Thelastone promette bene
Rif: Problemi con Visual C++ 2005

Amiga,temo che questo 3d dovrà continuare nella sezione degli infetti.

Ho riprovato ad installare il visual c++, con lo stesso risultato.

Seguendo il link che mi hai dato, M.soft tra l'alto indica di svuotare la cartella Temp (tra parentesi il Regedit cui si riferiscono è diverso dal mio - w7 64). Se al prompt dei comandi digito "del.*tmp" mi appare:
\Temp\JET645E.temp. Impossibile accedere al file. Il file è utilizzato da un altro processo.

E non è vero perché ho tutto spento.

Su Google JET645E è indicato come un trojan diun colombiano del 2009.
Che faccio, apro un altro 3d nella sicurezza o potete spostare questo?
Thelastone non è collegato   Rispondi citando
Vecchio 19-11-2013, 19.38.33   #6
AMIGA
Gold Member
Top Poster
 
L'avatar di AMIGA
 
Registrato: 06-07-2006
Loc.: Brindisi
Messaggi: 10.106
AMIGA è un gioiello raroAMIGA è un gioiello raroAMIGA è un gioiello raro
Rif: Problemi con Visual C++ 2005

Fai subito una pulizia delle temp e del registro con CCleaner, poi scansiona il sistema con Malwarebytes dopo averlo aggiornato e infine ripulisci gli ospiti indesiterati con AdwCleaner.


Può essere che stai usando un Installer Web con annessi connessi al seguito, probabilmente aiutati da qualche ospite che hai nel sistema, allega il link dove scarichi Visual C++ 2005, poi fai una prova con una versione full, se disattivi Internet durante l'installazione stai più sicuro, operzione consigliata che si dovrebbe sempre fare quando ci sono queste insidie.
___________________________________

Dove l'ho sentita ? www.plagimusicali.net

English Amiga Board Amiganews.it AfA One AROS x86 AROS 68k

Ultima modifica di AMIGA : 20-11-2013 alle ore 02.04.18
AMIGA non è collegato   Rispondi citando
Vecchio 20-11-2013, 00.27.29   #7
Thelastone
Junior Member
 
Registrato: 17-11-2008
Loc.: Bordighera
Messaggi: 66
Thelastone promette bene
Rif: Problemi con Visual C++ 2005

Eccomi qui.
Amiga, prima di tutto scusa per il pvt, non volevo disturbare, non avevo capito. Cancella.

Allora: fatta pulizia con Ccleaner, Malwarebytes mi ha trovato due PUP (chissà come mai, entrambi in Internet Explorer che è disattivato da anni) che ho quarantinato subito. Poi rifinito con Adwcleaner. Poi scaricato, masterizzato e installato, anzi cercato di installare Visual eccetera.
E qui la brutta notizia: arrivato circa al 15 per cento, bloccato e dopo mezz'ora ecco la solita finestra. Errore 1935 eccetera, tutto uguale identico agli altri.
Però dal pannello di controllo constato che il Remote debagger l'ha installato perché ne ho due.
Prima di cena avevo anche controllato con il Framework verification tool la validità del Net Framework installato da me, ed è regolare. Io dal pannello di controllo ne vedo uno, il 4 client profile, ma il tool ne ha trovato quattro (2 3 3.5 e 4) tutti regolari.

Non so cosa pensare, anche perché ci capisco poco.

Non è per esempio che sia Windows installer falloso o da sostituire (se non ho detto una fessseria enorme)?

Il link da cui scarico Visual C++ 2005 è quello Microsoft e cioè

http://www.microsoft.com/it-it/downl....aspx?id=18471

Resto in attesa di Pregiata Vostra...
Thelastone non è collegato   Rispondi citando
Vecchio 20-11-2013, 02.28.20   #8
AMIGA
Gold Member
Top Poster
 
L'avatar di AMIGA
 
Registrato: 06-07-2006
Loc.: Brindisi
Messaggi: 10.106
AMIGA è un gioiello raroAMIGA è un gioiello raroAMIGA è un gioiello raro
Rif: Problemi con Visual C++ 2005

Eccomi, non ti preoccupare per il pvt, letto solo ora, ero impegnato nella New Software. Riguardo l'errore, come riportano dal link fornito, pare essere un problema di installazioni corrotte di .NET Framework, brutta rogna, farò qualche altra ricerca per verificare se ci sono altre cause a generarlo. Adesso l'unica cosa che potresti fare è quella di disinstallare radicalmente tutti i .NET Framework e i Visual C++ 2005, ma devi farlo con un disinstallatore più potente in modo da eliminare ogni traccia nel registro puoi usare l'ottimo Your Uninstaller, si tratta di un programma commerciale ma lo si può usare per 21 giorni in prova, poi dopo un riavvio esegui questo Microsoft Fix it, fatto questo prova a riinstallare tutto, ma solo quello strettamente necessario. Ho notato solo ora che hai un sistema a 64Bit, quindi dovresti scaricare e installare sia il Visual C++ che NET Framework compatibile con questo sistema.
___________________________________

Dove l'ho sentita ? www.plagimusicali.net

English Amiga Board Amiganews.it AfA One AROS x86 AROS 68k
AMIGA non è collegato   Rispondi citando
Vecchio 20-11-2013, 17.07.05   #9
xilo76
Forum supporter
Global Moderator
 
Registrato: 23-08-2007
Messaggi: 2.703
xilo76 è conosciuto da tuttixilo76 è conosciuto da tuttixilo76 è conosciuto da tuttixilo76 è conosciuto da tutti
Rif: Problemi con Visual C++ 2005

Dovresti disinstallare tutti i visual c++ 2005 e installare questi:

Microsoft Visual C++ 2005 SP1 Redistributable Package (x64)
http://www.microsoft.com/en-us/downl....aspx?id=18471

Aggiornamento della protezione per ATL di Microsoft Visual C++ 2005 Service Pack 1 Redistributable Package
http://www.microsoft.com/it-it/downl....aspx?id=14431

(Più quelli che ti mostrerà winUpdate)
xilo76 non è collegato   Rispondi citando
Vecchio 20-11-2013, 20.33.48   #10
Thelastone
Junior Member
 
Registrato: 17-11-2008
Loc.: Bordighera
Messaggi: 66
Thelastone promette bene
Rif: Problemi con Visual C++ 2005

Grazie xilo76.
Come vedi dal link che ho indicato nel post nr 7, lo avevo già fatto ieri e lo stesso per l'altro. Per essere tranquillo, nella ultima ora ho riprovato con il secondo, ma nulla da fare, rispunta il solito errore e si blocca.

@Amiga, seguendo le tue indicazioni, ho fatto tutto: ho disinstallato con Your Unistaller il Net Famework 4 (il Visual C++ 2005 lo avevo già tolto ieri), ripulito con Microsoft Fix, scaricato e reinstallato il Net Framework 4 (ha impiegato tre ore e mezza), poi provato a scaricare ed installare quello stesso di prima (x64), ma inutilmente. Stessa finestra stesso errore.

Ho notato una cosa però: nella finestra degli errori, la fine della stringa è diversa. Le versioni dello stesso file visual c++ 2005 sono più d'una, e in quelle con ...(x86), la stringa termina con ...processor architecture="x86", mentre l'altra ...(x64) che dovrebbe essere quella giusta per me W7 64, termina con ...processor architecture="amd64".
La cosa mi pare strana. Non vorrei si riferisse ad un'altra cpu. Ma io ci capisco poco, come già detto , e forse è una fesseria.
Thelastone non è collegato   Rispondi citando
Vecchio 20-11-2013, 20.59.26   #11
AMIGA
Gold Member
Top Poster
 
L'avatar di AMIGA
 
Registrato: 06-07-2006
Loc.: Brindisi
Messaggi: 10.106
AMIGA è un gioiello raroAMIGA è un gioiello raroAMIGA è un gioiello raro
Rif: Problemi con

In effetti è strano, però credo che una incompatibilità di CPU non ti avrebbe permesso l'installazione; hai provato ad installare Microsoft Visual C++ 2008 al posto di Microsoft Visual C++ 2005 ? , potrebbe darti lo stesso errore, ma provare non ti costa nulla, prima però ripulisci tutto con Your Uninstaller.
___________________________________

Dove l'ho sentita ? www.plagimusicali.net

English Amiga Board Amiganews.it AfA One AROS x86 AROS 68k
AMIGA non è collegato   Rispondi citando
Vecchio 20-11-2013, 21.58.20   #12
Thelastone
Junior Member
 
Registrato: 17-11-2008
Loc.: Bordighera
Messaggi: 66
Thelastone promette bene
Rif: Problemi con Visual C++ 2005

Allora provo a fare una cosa, sempre perché tanto non costa nulla: faccio sparire tutti i visual, e cerco di reinstallarli tutti. Vediamo che succede... Tra un po' comincio.
Thelastone non è collegato   Rispondi citando
Vecchio 20-11-2013, 23.09.57   #13
Thelastone
Junior Member
 
Registrato: 17-11-2008
Loc.: Bordighera
Messaggi: 66
Thelastone promette bene
Rif: Problemi con Visual C++ 2005

Altra sorpresa: Your Uninstaller non riece a disinstallare i visual C. Compare una finestra che dice: Error. Access violation at 0x77253170 (tried to write to 0x00090FFC), program terminated.
E stop. Finisce lì. Dopo un po' si chiude ill programma. ("ha smesso di funzionare")

E ho controllato: tra i sette che ho installati, cinque del 2008 e due del 2010, sono misti, tre x64 e quattrro x86

Edit
Sto provando a toglierli dal pannello di controllo/disinstalla. È lentissimo, ma uno è andato, vedremo gli altri.
Thelastone non è collegato   Rispondi citando
Vecchio 21-11-2013, 19.49.36   #14
Thelastone
Junior Member
 
Registrato: 17-11-2008
Loc.: Bordighera
Messaggi: 66
Thelastone promette bene
Rif: Problemi con Visual C++ 2005

Aggiornamento della situazione.

Disinstallati a mano tutti i Visual C++ poi reinstallati i due Visual 2010, i più recenti, -x64 e x86 -, stando al sito M.ft necessitano uno dell'altro. Ci sono volute ore.

Provato ad installare Cyber Link ma dopo un po', eccolo:

"Il processo non può proseguire perché l'installazione (Microsoft Visual C++ 2005 Service Pack 1 Redistributable Package ATL Security Update (x86)) non è riuscita. Contattare il supporto tecnico Microsoft per assistenza. L'installazione verrà annullata".

Provato ad installare il Visual C2005 di cui si parla, ma come ieri

"Errore 1935. Errore durante l'installazione dell'assembly.
Microsoft.VC80.Open MP type="win32", version="8.0.50727.762", publicKeyToken="1fc8b3b9a1e18e3b", processor architecture="x86".
Per ulteriori informazioni, vedere guida e supporto tecnico.

Provato ad installare l'altra versione x64, risultato identico.

Non so cosa fare.
Provare ad installare gli altri visual 2008 ed i framework 2 3 e 3.5?
O spiegare le cose al PC col martello?
Thelastone non è collegato   Rispondi citando
Vecchio 21-11-2013, 19.52.41   #15
xilo76
Forum supporter
Global Moderator
 
Registrato: 23-08-2007
Messaggi: 2.703
xilo76 è conosciuto da tuttixilo76 è conosciuto da tuttixilo76 è conosciuto da tuttixilo76 è conosciuto da tutti
Rif: Problemi con Visual C++ 2005

Hai provato a schivare il problema con imgburn?
Dato che non usa né MFC mè ATL, non dovrebbe dare problemi.
L'antivirus potrebbe essere comunque il colpevole... Provato a disabilitarlo durante l'installazione?
Qualcuno ha scaricato e installato questo: http://download.cnet.com/Microsoft-V...c3289c791ed268
Un altro ha aggiunto un meno in una voce del registro:
Codice:
HKEY_CLASSES_ROOT\Installer\Products\-F942F94A19C0F79468FD2B85E5E8677B
xilo76 non è collegato   Rispondi citando
Rispondi


Utenti attualmente attivi che stanno leggendo questa discussione: 1 (0 utenti e 1 ospiti)
 
Strumenti discussione

Regole di scrittura
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is ON
Gli smilies sono ON
[IMG] è ON
Il codice HTML è OFF

Vai al forum

Discussioni simili
Discussione Autore discussione Forum Risposte Ultimo messaggio
Scan di HijackThis da sottoporvi Cloro Sicurezza&Privacy 2 19-02-2005 16.01.27
problemi con floppy - penna usb - lettore cd Alberto.m Windows 7/Vista/XP/ 2003 2 07-02-2005 14.41.54
problemi con floppy penne usb e lettore cd Alberto.m Windows 9x/Me/NT4/2000 2 06-02-2005 20.46.53
norton 2005 problemi... Menz Sicurezza&Privacy 4 24-12-2004 13.41.09
PowerPack 2005 1.5 Gervy Archivio News Software 0 19-12-2004 09.57.14

Orario GMT +2. Ora sono le: 13.28.05.


E' vietata la riproduzione, anche solo in parte, di contenuti e grafica.
Copyright © 1999-2017 Edizioni Master S.p.A. p.iva: 02105820787 • Tutti i diritti sono riservati
L'editore NON si assume nessuna responsabilità dei contenuti pubblicati sul forum in quanto redatti direttamente dagli utenti.
Questi ultimi sono responsabili dei contenuti da loro riportati nelle discussioni del forum
Powered by vBulletin - 2010 Copyright © Jelsoft Enterprises Limited.