Telefonino.net network
 
| HOMEPAGE | INDICE FORUM | REGOLAMENTO | ::. NEI PREFERITI .:: | RSS Forum | RSS News | NEWS web | NEWS software |
| PUBBLICITA' | | ARTICOLI | WIN XP | VISTA | WIN 7 | REGISTRI | SOFTWARE | MANUALI | RECENSIONI | LINUX | HUMOR | HARDWARE | DOWNLOAD | | CERCA nel FORUM » |

Torna indietro   WinTricks Forum > Sistemi Operativi > Linux e altri Sistemi Operativi

Notices

Rispondi
 
Strumenti discussione
Vecchio 23-10-2004, 19.20.09   #1
Eteria
Hero Member
 
Registrato: 24-05-2000
Loc.: Ibiza
Messaggi: 1.229
Eteria promette bene
[LINUX] Kernel 2.6.9 e drivers nvidia

Vi risulta che ci siano dei problemi a installare il driver per schede video nvidia su un sistema con kernel 2.6.9 appena ricompilato???
Io ci ho provato oggi ma mi da un messaggio di errore: dice che i sorgenti del kernel a disposizione non sono quelli del kernel in uso. Il pacco che da sempre lo stesso messaggio sia provando a fargli rintracciare il path in automatico sia provando a forzare il path ... la prima volta che mi capita una roba del genere, per ora vado avanti col kernel 2.6.7 su cui il driver nvidia si installa senza problemi di nessun tipo sperando che ci sia una soluzione ...
Eteria non  collegato   Rispondi citando
Vecchio 23-10-2004, 20.06.55   #2
pholcus
Linux Supporter
 
L'avatar di pholcus
 
Registrato: 02-12-2000
Loc.: Monza
Messaggi: 1.987
pholcus promette bene
Strano..da me tutto bene..Hai provato a disinstalare prima i driver vecchi?
pholcus non  collegato   Rispondi citando
Vecchio 23-10-2004, 20.58.44   #3
ANDY CAPS
Hero Member
 
L'avatar di ANDY CAPS
 
Registrato: 15-09-2002
Loc.: siena
Messaggi: 1.101
ANDY CAPS promette bene
anche a me da lo stesso errore
(provato con vari so )


prova il nuovo 2.6.10-rc1
http://www.kernel.org/pub/linux/kern....10-rc1.tar.gz

nvidia dovrebbe rilasciare ( si spera a breve i nuovi driver compatibili con il kernel 2.6.9

___________________________________

.................AND.................

Ultima modifica di ANDY CAPS : 24-10-2004 alle ore 01.23.32
ANDY CAPS non  collegato   Rispondi citando
Vecchio 23-10-2004, 22.25.31   #4
Eteria
Hero Member
 
Registrato: 24-05-2000
Loc.: Ibiza
Messaggi: 1.229
Eteria promette bene
Quota:
Originariamente inviato da ANDY CAPS
... nvidia dovrebbe rilasciare ( si psera a breve i nuovi driver compatibili con il kernel 2.6.9
mmmh di riprovare a ricompilare il kernel non ne ho tanta voglia anche perch se avessi fatto qualche errore di compilazione come minimo non mi si caricherebbe una ceppa (a partire dai moduli se non il kernel stesso), tra l'altro di messaggi di errore non ne ho avuti e la configurazione pari pari alla configurazione del kernel precedente ... forse mi conviene appunto aspettare un pochino che magari rilasciano un driver nuovo che mette a posto qua e la qualche bug ...
Disinstallare i drivers precedenti no ho provato per un motivo che mi sembra scontato: kernel di una versione pi recente di quello che ho installato, ricompilato con moduli quindi ricompilati anch'essi, in /lib/modules/2.6.9 non c' sicuramente traccia di una precedente installazione dei drivers nvidia.
Eteria non  collegato   Rispondi citando
Vecchio 24-10-2004, 01.22.47   #5
ANDY CAPS
Hero Member
 
L'avatar di ANDY CAPS
 
Registrato: 15-09-2002
Loc.: siena
Messaggi: 1.101
ANDY CAPS promette bene
si poi tanto non vanno nemmeno questi

aspetteremo fiduciosi i nuovi driver nvidia imminenti

fino alla rc2 del 2.6.9 comunque vanno benissimo
io lo reinstallero
___________________________________

.................AND.................
ANDY CAPS non  collegato   Rispondi citando
Vecchio 24-10-2004, 12.13.49   #6
pholcus
Linux Supporter
 
L'avatar di pholcus
 
Registrato: 02-12-2000
Loc.: Monza
Messaggi: 1.987
pholcus promette bene
Scusate che distribuzione avete?

Eteria, dammi retta prova anche a disinstallarli..

Pero' prima prova ad installarli con queste opzioni se nn l'hai gia' fatto, cosi:

scompatti i driver ( pkg0 ) entri nella directory dei driver, modifichi come vuoi le impostazioni di default nel file os-registry.c, poi dai il comando:

./nvidia-installer --kernel-name=`uname -r` -K

Io li installo cosi per avere diversi kernel funzionanti e per ognuno i driver nvidia installati..

Provo ora a mettere kernel 2.6.10rc1..e vi faccio sapere se vanno anche con questo..

Ciao
pholcus non  collegato   Rispondi citando
Vecchio 24-10-2004, 21.24.05   #7
Eteria
Hero Member
 
Registrato: 24-05-2000
Loc.: Ibiza
Messaggi: 1.229
Eteria promette bene
Quota:
Originariamente inviato da pholcus
Scusate che distribuzione avete?

Eteria, dammi retta prova anche a disinstallarli..

Pero' prima prova ad installarli con queste opzioni se nn l'hai gia' fatto, cosi:

scompatti i driver ( pkg0 ) entri nella directory dei driver, modifichi come vuoi le impostazioni di default nel file os-registry.c, poi dai il comando:

./nvidia-installer --kernel-name=`uname -r` -K

Io li installo cosi per avere diversi kernel funzionanti e per ognuno i driver nvidia installati..

Provo ora a mettere kernel 2.6.10rc1..e vi faccio sapere se vanno anche con questo..

Ciao
Fica sta cosa!!! Stasera ci provo e poi vengo a dirvi cosa mi successo
Eteria non  collegato   Rispondi citando
Vecchio 25-10-2004, 01.18.05   #8
pholcus
Linux Supporter
 
L'avatar di pholcus
 
Registrato: 02-12-2000
Loc.: Monza
Messaggi: 1.987
pholcus promette bene
MI correggo ho detto una semi cavolata...

Il driver si installa,ma nn mi viene caricato


Da come errore vmalloc_reserve symbol not found..

Non vorrei aver tolto troppa roba al kernel..provate anche voi e sappiatemi dire..
pholcus non  collegato   Rispondi citando
Vecchio 25-10-2004, 13.12.48   #9
Eteria
Hero Member
 
Registrato: 24-05-2000
Loc.: Ibiza
Messaggi: 1.229
Eteria promette bene
Niente, non mi funziona, ho provato a fare come hai scritto, succede che installa il modulo dentro una cartella diversa da /lib/modules/2.6.9/... e termina pure l'installazione senza problemi ma alla fine appunto non riesce a caricare il modulo in questione. Non so se perch non lo trova o perch il modulo in questione non va bene. Credo comunque sia per quest'ultima ipotesi visto che i tentativi di installazione precedenti che ho provato in modo diverso da quello consigliato da Pholcus si interrompevano con la stessa anomalia: dopo avermi compilato il modulo non riusciva a caricarlo e non proseguiva. Attendo prossimo driver nvidia, peccato perch il 6101 sul mio sistema spettacolare.
Eteria non  collegato   Rispondi citando
Vecchio 25-10-2004, 13.49.34   #10
pholcus
Linux Supporter
 
L'avatar di pholcus
 
Registrato: 02-12-2000
Loc.: Monza
Messaggi: 1.987
pholcus promette bene
Patch da applicare al kernel in attesa che rilascino nuovi driver:

Codice:
--- a/arch/i386/mm/init.c 2004-09-21 19:26:29.564841416 +0200
+++ b/arch/i386/mm/init.c 2004-09-21 17:38:25.000000000 +0200
@@ -41,6 +41,7 @@
#include <asm/sections.h>

unsigned int __VMALLOC_RESERVE = 128 << 20;
+EXPORT_SYMBOL(__VMALLOC_RESERVE);

DEFINE_PER_CPU(struct mmu_gather, mmu_gathers);
unsigned long highstart_pfn, highend_pfn;
Ciao
pholcus non  collegato   Rispondi citando
Vecchio 25-10-2004, 14.55.14   #11
Eteria
Hero Member
 
Registrato: 24-05-2000
Loc.: Ibiza
Messaggi: 1.229
Eteria promette bene
Aspe aspe come si usa???
Eteria non  collegato   Rispondi citando
Vecchio 25-10-2004, 16.08.58   #12
pholcus
Linux Supporter
 
L'avatar di pholcus
 
Registrato: 02-12-2000
Loc.: Monza
Messaggi: 1.987
pholcus promette bene
allora salva la patch in un file nvidia.patch nella directory /usr/src , poi, poi fai cd /usr/src/linux, poi applichi la patch con:
patch -p1 < ../nvidia.patch

Altrimenti apri il file /usr/src/linux/arch/i386/mm/init.c cerchi le ricghe sopra indicate e aggiungi la linea preceduta dal + senza il +, cioe' questa:

+EXPORT_SYMBOL(__VMALLOC_RESERVE);
pholcus non  collegato   Rispondi citando
Vecchio 25-10-2004, 18.18.27   #13
pholcus
Linux Supporter
 
L'avatar di pholcus
 
Registrato: 02-12-2000
Loc.: Monza
Messaggi: 1.987
pholcus promette bene
Altra cosa da sistemare.. unknown symbol pci_find_class, perche' negli ultimi kernel e' stata sostituita da pci_get_class

Vi allego il file modificato...togliete l'estensione .zip e sovrascrivete il file presente nei driver nvidia..ora funziona tutto, anche con il kernel 2.6.10-rc1


PS: che bello nn dover aspettare i produttori hardware che fixano i driver...
pholcus non  collegato   Rispondi citando
Vecchio 26-10-2004, 01.03.45   #14
Eteria
Hero Member
 
Registrato: 24-05-2000
Loc.: Ibiza
Messaggi: 1.229
Eteria promette bene
Nada, non riesco, mi dava errore a patchare il kernel e allora ho editato a mano il file /usr/src/linux/arch/i386/mm/init.c e mi si blocca la compilazione del kernel con un errore

Ci speravo a farlo andare, ci tengo a far andare la scheda video con il driver 6106 che per giocare a UT2004 non ci sono palle, il pi fluido di tutti.
Eteria non  collegato   Rispondi citando
Vecchio 26-10-2004, 01.16.43   #15
pholcus
Linux Supporter
 
L'avatar di pholcus
 
Registrato: 02-12-2000
Loc.: Monza
Messaggi: 1.987
pholcus promette bene
Cioe'? che errore? Hai tolto il +davanti alla riga? La linea da editare e' circa alla linea 42 o giu di li..
pholcus non  collegato   Rispondi citando
Rispondi


Utenti attualmente attivi che stanno leggendo questa discussione: 1 (0 utenti e 1 ospiti)
 
Strumenti discussione

Regole di scrittura
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is ON
Gli smilies sono ON
Il codice HTML OFF

Vai al forum

Discussioni simili
Discussione Autore discussione Forum Risposte Ultimo messaggio
[SLACK] Problema webcam Quickcam Express Logitech User458 Linux e altri Sistemi Operativi 0 04-02-2008 20.54.26
Nvidia drivers Gervy Archivio News Web 2 23-05-2007 22.01.57
[linux] Driver NVidia e kernel wolverin Linux e altri Sistemi Operativi 2 14-12-2006 22.02.11
Nvidia nForce drivers Gervy Archivio News Web 2 18-09-2004 14.37.16
[LINUX] Problema con dirvers Nvidia Topov Linux e altri Sistemi Operativi 1 17-07-2004 22.59.19

Orario GMT +2. Ora sono le: 17.37.02.


E' vietata la riproduzione, anche solo in parte, di contenuti e grafica.
Copyright 1999-2017 Edizioni Master S.p.A. p.iva: 02105820787 Tutti i diritti sono riservati
L'editore NON si assume nessuna responsabilità dei contenuti pubblicati sul forum in quanto redatti direttamente dagli utenti.
Questi ultimi sono responsabili dei contenuti da loro riportati nelle discussioni del forum
Powered by vBulletin - 2010 Copyright Jelsoft Enterprises Limited.