Telefonino.net network
 
| HOMEPAGE | INDICE FORUM | REGOLAMENTO | ::. NEI PREFERITI .:: | RSS Forum | RSS News | NEWS web | NEWS software |
| PUBBLICITA' | | ARTICOLI | WIN XP | VISTA | WIN 7 | REGISTRI | SOFTWARE | MANUALI | RECENSIONI | LINUX | HUMOR | HARDWARE | DOWNLOAD | | CERCA nel FORUM » |

Torna indietro   WinTricks Forum > Software > Software applicativo

Notices

Rispondi
 
Strumenti discussione
Vecchio 18-02-2004, 18.42.29   #1
Gabry
Forum supporter
 
L'avatar di Gabry
 
Registrato: 28-04-2003
Loc.: Svizzera, ma con passaporto UEE (molisano di origine... )
Messaggi: 1.820
Gabry promette bene
Calcolo ore di lavoro con Excel

Ho questo tipo di problema:

devo calcolare l'orario di lavoro, tenendo in considerazione i turni notturni. Cosa mi succede? le celle sono formattate per l'inserimento dei numeri in formato orario, e ho inserito la seguente formula.

=((C26-B26)+(E26-D26)-H26)

Ma il risultato fallisce dal momento in cui, supponiamo, vi é l'inizio dell'attivita lavorativa alle 22°° di sera (C26), e l'uscita alle 4°° del mattino (B26), il risultato finale dovrebbe essere di 6:00 ore lavorative, ed invece nella casella mi appare tutta una serie di diesis (##########), ad indicare che il calcolo non é possibile.
Per ovviare al problema devo sempre terminare il calcolo alle 00:00 per indicare le 24°°, e riprendere da 00:01, con però un risultato che mi si falsa di 1 minuto.

Avete soluzioni in merito?
Grazie.
___________________________________

ma a voi non capita di pensare a Gesù?
http://ccegv.altervista.org
Gabry non è collegato   Rispondi citando
Vecchio 18-02-2004, 19.07.08   #2
TyDany
WT Italian Team Leader
Top Poster
 
L'avatar di TyDany
 
Registrato: 07-11-2001
Loc.: Everywhere with Monster Fede: Desmocredente
Messaggi: 7.677
TyDany promette bene
http://www.nuska2000.it/oraridilavoro.htm

Il must imho
___________________________________


www.TyDany.it News! -> Il mio sito... la mia vita e le mie passioni...
TyFoto.it -> TyDany Fotografia, fotografie sportive, ritratti, paesaggi...
Tutto quello che è stato ora non è più... come un colpo di spugna che tutto cancella...
TyDany non è collegato   Rispondi citando
Vecchio 18-02-2004, 20.18.03   #3
Gabry
Forum supporter
 
L'avatar di Gabry
 
Registrato: 28-04-2003
Loc.: Svizzera, ma con passaporto UEE (molisano di origine... )
Messaggi: 1.820
Gabry promette bene
Grazie per il link, ho scaricato i fogli di lavoro, é un programma molto ben studiato, anche se però il problema permane. Anche in questo caso, metti che inizio alle 22:00, e esco alle 6:00, il programma mi presenta i soliti ######, stesso problema che ho con il mio foglio di calcolo.
___________________________________

ma a voi non capita di pensare a Gesù?
http://ccegv.altervista.org
Gabry non è collegato   Rispondi citando
Vecchio 18-02-2004, 20.58.19   #4
exion
Guest
 
Messaggi: n/a
devi inserire una formula se

te le semplifico sulla prima parte della tua formula, almeno per capire:

=SE(B26<C26;24-(C26-B26);C26-B26)

Che in sostanza esegue questo:

- Se l'orario di fine lavoro è minore dell'orario di inizio, significa che è passato un giorno. Si sottrae l'orario di fine all'orario di inizio (per ottenere un risultato non negativo), e si sottrae il risultato alle 24 ore del giorno (24-(C26-B26))

- Se l'orario di fine lavoro è maggiore dell'orario di inizio, significa che inizio e fine si situano sullo stesso giorno è basta quindi sottrarre normalmente (C26-B26)
  Rispondi citando
Vecchio 18-02-2004, 22.42.21   #5
Gabry
Forum supporter
 
L'avatar di Gabry
 
Registrato: 28-04-2003
Loc.: Svizzera, ma con passaporto UEE (molisano di origine... )
Messaggi: 1.820
Gabry promette bene
Perfetto adesso funziona anche se però l'ho dovuta corregere in questo modo:
=SE(B26>C26;24-(B26-C26);C26-B26)
___________________________________

ma a voi non capita di pensare a Gesù?
http://ccegv.altervista.org
Gabry non è collegato   Rispondi citando
Vecchio 18-02-2004, 22.47.27   #6
exion
Guest
 
Messaggi: n/a
Quota:
Originariamente inviato da Gabry
Perfetto adesso funziona anche se però l'ho dovuta corregere in questo modo:
=SE(B26>C26;24-(B26-C26);C26-B26)

sì giusto, ho sbagliato a trascrivere, infatti nel foglio di prova che ho fatto era C26<B26, ho invertito le celle
  Rispondi citando
Vecchio 18-02-2004, 23.06.10   #7
TyDany
WT Italian Team Leader
Top Poster
 
L'avatar di TyDany
 
Registrato: 07-11-2001
Loc.: Everywhere with Monster Fede: Desmocredente
Messaggi: 7.677
TyDany promette bene
Quota:
Originariamente inviato da Gabry
Grazie per il link, ho scaricato i fogli di lavoro, é un programma molto ben studiato, anche se però il problema permane. Anche in questo caso, metti che inizio alle 22:00, e esco alle 6:00, il programma mi presenta i soliti ######, stesso problema che ho con il mio foglio di calcolo.
io prima di linkartelo ho provato, ho messo inizio 22 e uscita 4 e mi ha segnato 6 ore esatte
___________________________________


www.TyDany.it News! -> Il mio sito... la mia vita e le mie passioni...
TyFoto.it -> TyDany Fotografia, fotografie sportive, ritratti, paesaggi...
Tutto quello che è stato ora non è più... come un colpo di spugna che tutto cancella...
TyDany non è collegato   Rispondi citando
Vecchio 18-02-2004, 23.21.58   #8
Gabry
Forum supporter
 
L'avatar di Gabry
 
Registrato: 28-04-2003
Loc.: Svizzera, ma con passaporto UEE (molisano di origine... )
Messaggi: 1.820
Gabry promette bene
Probabilmente é colpa delle impostazioni di tastiera, io devo digitare le ore e minuti separate dai :.

Forse é questo. Comunque ho riprovato, ma l'errore riame.
___________________________________

ma a voi non capita di pensare a Gesù?
http://ccegv.altervista.org
Gabry non è collegato   Rispondi citando
Vecchio 18-02-2004, 23.30.39   #9
TyDany
WT Italian Team Leader
Top Poster
 
L'avatar di TyDany
 
Registrato: 07-11-2001
Loc.: Everywhere with Monster Fede: Desmocredente
Messaggi: 7.677
TyDany promette bene
Forse ho capito, per ogni giorno in quel foglio c'è:

-entrata mattino
-uscita mattino
-entrata pomeriggio
-uscita pomeriggio

Devi mettere le 22 nel primo e le 4 nel secondo, se le 4 le metti nel quarto sballa i calcoli
___________________________________


www.TyDany.it News! -> Il mio sito... la mia vita e le mie passioni...
TyFoto.it -> TyDany Fotografia, fotografie sportive, ritratti, paesaggi...
Tutto quello che è stato ora non è più... come un colpo di spugna che tutto cancella...
TyDany non è collegato   Rispondi citando
Vecchio 21-02-2004, 12.07.37   #10
Gabry
Forum supporter
 
L'avatar di Gabry
 
Registrato: 28-04-2003
Loc.: Svizzera, ma con passaporto UEE (molisano di origine... )
Messaggi: 1.820
Gabry promette bene
Ho preferito crearmene uno io, in quanto quello scaricato poi non mi permette di calcolare lo stipendio.
Ora però ho questi 2 problemi da risolvere:

1)
La somma delle ore di lavoro: ogni qual volta mi supera le 24 ore mi ripare da 0. Quindi su una settimana di lavoro di 8 ore, invece di avere un totale di 40 ore, mi risultano 16 ore di lavoro (le celle sono formattate come orario "hh.mm")

2)
In base al totale delle ore lavorate, devo moltiplicare per la tariffa oraria del dipendente, ma la formula da me impostata non mi funziona. Faccio questo esempio:

Ho il risultato delle ore di lavoro in H53 (cella formattata come orario con "hh.mm"), e in H60 ho la tariffa oraria del dipendente (cella formatata come valuta con 2 decimali), in H62 mi dovrebbe dare il totale, quindi supponiamo di dover moltiplicare 20 ore di lavoro per 19.- (nel mio caso CHF.) dovrebbe darmi 380.- e invece mi risulta 1782.83. Ho impostato la seguente formula: =SOMMA(H53*H60).

Cosa sbaglio, la formula o la formattazione delle celle?
___________________________________

ma a voi non capita di pensare a Gesù?
http://ccegv.altervista.org
Gabry non è collegato   Rispondi citando
Vecchio 22-02-2004, 14.27.53   #11
Gabry
Forum supporter
 
L'avatar di Gabry
 
Registrato: 28-04-2003
Loc.: Svizzera, ma con passaporto UEE (molisano di origine... )
Messaggi: 1.820
Gabry promette bene
Scusate se insisto

Ragazzi vi allego il foglio in questione.

Sapete risolvermi il problema? Oppure provatelo sul vostro PC, magari ho un baco nel mio sistema, poi ditemi se da voi il totale vi risulta corretto.

Se notate nella cella J35 dovrebbe esserci il totale delle ore di lavoro che ammontano a 42:30, ed invece come già spiegato prima mi segna 18:30 in quanto dopo la 24° ora mi riparte da 0.

Mi fate sapere? Grazie.
___________________________________

ma a voi non capita di pensare a Gesù?
http://ccegv.altervista.org
Gabry non è collegato   Rispondi citando
Vecchio 22-02-2004, 15.34.12   #12
exion
Guest
 
Messaggi: n/a
Rivisto e corretto

il tuo problema nasce dal formato particolare con cui Excel interpreta le ore del giorno.

nel foglio allegato ho fatto queste modifiche:

- aggiunto due colonne (N e O) per convertire i valori di L e M dal formato "Ora" al formato "Numero"

- inserito la seguente formula in N:
=SE(L3>23;(L3-23)*24;L3*24)

- copiato-incollato la stessa formula in O, che quindi diventa:
=SE(M3>23;(M3-23)*24;M3*24)

- modificata la formula in J con
=(N3+O3)-I3

- modificato il formato celle in tutta la colonna J ("numero", un decimale)

Ultima modifica di exion : 22-02-2004 alle ore 15.44.21
  Rispondi citando
Vecchio 22-02-2004, 15.43.22   #13
exion
Guest
 
Messaggi: n/a
volendo c'è anche un modo più raffinato di farlo, integrando la conversione da ora in numero direttamente nella formula che verifica il passaggio da un giorno all'altro:

- Cambi le formule in L e M con rispettivamente:
=SE(C3>D3;24-((C3*24)-(D3*24));(D3*24)-(C3*24))
e
=SE(E3>F3;24-((E3*24)-(F3*24));(F3*24)-(E3*24))
- Cambi il formato delle colonne J, L e M da "ora" in "numero" con 1 decimale

fatto
  Rispondi citando
Vecchio 22-02-2004, 15.52.31   #14
Gabry
Forum supporter
 
L'avatar di Gabry
 
Registrato: 28-04-2003
Loc.: Svizzera, ma con passaporto UEE (molisano di origine... )
Messaggi: 1.820
Gabry promette bene
WHHHHOOOOOOOUUUUUU.....
Sapessi le ore che ci ho passato per trovare una soluzione.

Ti ringrazio molto!
___________________________________

ma a voi non capita di pensare a Gesù?
http://ccegv.altervista.org
Gabry non è collegato   Rispondi citando
Rispondi


Utenti attualmente attivi che stanno leggendo questa discussione: 1 (0 utenti e 1 ospiti)
 
Strumenti discussione

Regole di scrittura
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is ON
Gli smilies sono ON
[IMG] è ON
Il codice HTML è OFF

Vai al forum

Discussioni simili
Discussione Autore discussione Forum Risposte Ultimo messaggio
[errore] fogli di calcolo di works 2000 e anteprima di stampa taniservice Software applicativo 7 23-06-2006 17.48.16
Calcolo viaggio con Excel Zenit Office suite 13 07-02-2006 00.55.26
Excel calcolo orari Zenit Office suite 8 28-12-2005 01.54.16
Excel: nomi intervalli celle su più fogli Potino78 Office suite 2 05-04-2005 14.48.06
Diritti e doveri di lavoro Part-time Kjow Chiacchiere in libertà 5 09-11-2004 15.11.51

Orario GMT +2. Ora sono le: 22.35.56.


E' vietata la riproduzione, anche solo in parte, di contenuti e grafica.
Copyright © 1999-2017 Edizioni Master S.p.A. p.iva: 02105820787 • Tutti i diritti sono riservati
L'editore NON si assume nessuna responsabilità dei contenuti pubblicati sul forum in quanto redatti direttamente dagli utenti.
Questi ultimi sono responsabili dei contenuti da loro riportati nelle discussioni del forum
Powered by vBulletin - 2010 Copyright © Jelsoft Enterprises Limited.