Visualizza messaggio singolo
Vecchio 17-06-2005, 00.28.04   #1
borgata
Gold Member
WT Expert
 
L'avatar di borgata
 
Registrato: 23-06-2004
Loc.: Cagliari
Messaggi: 13.333
borgata è un gioiello raroborgata è un gioiello raroborgata è un gioiello raroborgata è un gioiello raro
Autologin e password in chiaro! O_o

Smanettando con login e password, ho provato a creare una password per il mio account amministratore.
Avenndo impostato il login automatico (mettendo defaultUserName col nome del mio account e forceAutoLogon ad 1), ora non riesce più a connetersi perchè, appunto, non ha la password necessaria.
Ho visto allora un campo interessante, "DefaultPassword", e mi son detto, proviamo a mettere qui la password. La scrivo e... CRISBIO, È IN CHIARO!!!! Non funzionerà di sicuro allora, mi son detto.
Invece funziona. Si logga correttamente senza chiedermi la password.

Ora, ciò che volevo ottenere l'ho ottenuto, ma... non ho intenzione di lasciare la mia password in chiaro nel registro!!!

C'è un modo alternativo per loggarsi in automatico ad un account con password? O perlo meno un modo per evitare la password in chiaro...

Oltretutto l'uso di forceAutoLogon ha un lieve difetto. Sopportabile, ma se non ci fosse sarebbe meglio: quando disconnetto l'account, questo si rilogga automaticamente impedendo di fatto l'accesso ad altri account. Se invece utilizzo il "cambia utente" al posto della disconnessione vera e propria, funziona.
Qualche soluzione?
___________________________________

La risposta è dentro di te...
e però, è sbagliata!
borgata non è collegato   Rispondi citando