PDA

Visualizza versione completa : [LINUX] Sim city 3000 su linux?


Longhorn
18-12-2005, 20.40.50
Ho cercato in giro per simcity 3000 su linux,ma non ci ho capito un granche,devo comprare il gioco installare qualcos'altro?
MArco

Eteria
18-12-2005, 20.59.24
Non sono un fan di Simcity, ma solitamente per i videogames su Linux ci sono tre situazioni: o open source, e ti scarichi aggratis il sorgente o i binari compilati dall'autore e sei a posto. O un normale videogame che trovi sugli scaffali del supermercato assieme agli altri e gli autori ne hanno fortunatamente compilata una versione per Linux. O infine un giochino per windows e basta, e a sto punto puoi provare a farlo girare su Linux con degli emulatori, il pi famoso tra questi Wine (opensource), poi c' Cedega (a pagamento se vuoi usarlo per giocare in rete) che un estratto da wine, studiato apposta per i videogames, se vuoi testarlo e cerchi informazioni, sul sito del produttore c' pure un database dei giochi supportati (io con Cedega mi trovo malissimo).

http://www.transgaming.com/

ANDY CAPS
18-12-2005, 21.45.54
ftp://ftp.planetmirror.com/pub/lokigames/demos/

simcity 3000 esiste anche per linux
http://www.linuxjournal.com/node/4638/print
non so se sui cd ha l'installer per linux

dal link sopra scarichi il demo installer che installa alcune demo e dovrebbe avere anche i files per installare la versione full

Longhorn
09-01-2006, 20.14.36
Ho trovato il gioco in una biblioteca. L'ho installato senza problemi e in fondo mi ha detto:
per giocare digita sc3u.
Digito da esegui po invio e non si apre nulla.
Se dalla console,da root nella cartella dove c' il file sc3u mi dice:
sc3u: relocation error: sc3u: symbol _dl_global_scope, version GLIBC_2.0 not defined in file ld-linux.so.2 with link time reference

Cosa devo fare?

ANDY CAPS
09-01-2006, 21.19.28
si purtoppo le nuove glibc non sono piu compatibili con il gioco

andava bene con quelli delle distro' di un annetto fa

puoi provare ad aggiornare con loki-update http://www.liflg.org/index.php?catid=4 o seguire questa guida
http://ubuntuforums.org/showthread.php?t=21087&page=2


anche a me loki-demo fa partire solamente railroad tycon 2

Longhorn
10-01-2006, 13.49.51
Funziona!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Grazie :eek: :eek: :act: