PDA

Visualizza versione completa : [SuSe] 10.0 - Il PC non si spegne


Dr_House
08-11-2005, 04.14.28
Ho un piccoloproblemino con SuSe che mi fa da quando l'ho installato sul PC.

Lui vorrebbe spegnere come windows il PC in automatico, ma all'improvviso, dopo il solito click che sendo quando si spegne il PC, la schermata si blocca e rimane acceso il PC che devo spegnere io manualmente premendo il tasto.

Cosa può essere? un errore? un impostazione sbagliata?

Grazie

Ghandalf
08-11-2005, 09.57.05
Ma lo faceva anche prima? Se no, da quando ha cominciato (dopo un agg. ad esempio)?

Downloader
08-11-2005, 11.48.49
Io ho risolto con mdv abilitando l'ACPI e disabilitando APIC.

Dr_House
08-11-2005, 13.14.32
Lo dall'installazione questo

Provo a vedere quello che suggerisce downloader

Eteria
08-11-2005, 16.32.33
Confermo Downloader, pure a me Suse dava lo stesso problema che ho risolto abilitando l'ACPI.

Dr_House
08-11-2005, 17.03.12
ehm.. scusate l'ignoranza ma, com'è che si fa?

Downloader
08-11-2005, 17.13.53
Ora sono sotto win e potrei toppare, ma dovresti andare nel centro di controllo per andare a modificare il bootloader, da la trovi tutto.

Dr_House
08-11-2005, 17.31.49
non lo trovo sfortunatamente, trovo il bootloader ma non questo

wolverin
08-11-2005, 19.04.44
Non credo sia un problema di bootloader ma di script di avvio che non caricano il modulo per lo spegnimento

wolverin
09-11-2005, 00.28.32
Io uso la slack ed ho abilitato il caricamento (si tratta di togliere un cancelletto da una riga) del modulo APM per far spegnere il pc automaticamente. Io ho messo mano all'interno di rc.modules in /etc/rc.d per la suse non so essere più preciso non l'ho mai provata

Dr_House
09-11-2005, 00.43.50
io non vorrei andare a modificare degli script ma se proprio devo lo faccio appena ho un po di tempo libero.

Anche se, preferirei intraprendere la strada esposta da Downloader che pare più semplice...

Eteria
09-11-2005, 01.55.31
Io per risolverlo ho compilato il kernel con questa configurazione della sezione ACPI:

#
# ACPI (Advanced Configuration and Power Interface) Support
#
CONFIG_ACPI=y
CONFIG_ACPI_BOOT=y
CONFIG_ACPI_INTERPRETER=y
CONFIG_ACPI_SLEEP=y
CONFIG_ACPI_SLEEP_PROC_FS=y
CONFIG_ACPI_AC=m
# CONFIG_ACPI_BATTERY is not set
CONFIG_ACPI_BUTTON=y
CONFIG_ACPI_VIDEO=m
CONFIG_ACPI_FAN=m
CONFIG_ACPI_PROCESSOR=m
CONFIG_ACPI_THERMAL=m
# CONFIG_ACPI_ASUS is not set
# CONFIG_ACPI_IBM is not set
# CONFIG_ACPI_TOSHIBA is not set
CONFIG_ACPI_BLACKLIST_YEAR=0
# CONFIG_ACPI_DEBUG is not set
CONFIG_ACPI_BUS=y
CONFIG_ACPI_EC=y
CONFIG_ACPI_POWER=y
CONFIG_ACPI_PCI=y
CONFIG_ACPI_SYSTEM=y
# CONFIG_X86_PM_TIMER is not set
# CONFIG_ACPI_CONTAINER is not set

Dal successivo riavvio in poi non ho più avuto problemi.

Dr_House
09-11-2005, 13.55.36
Grazie Eteria adesso ci provo!

devo anche vedere come compilare ilkernel dato che questa è la mia prima volta che intervengo così radicalmente :P

Sono andato nella cartella etc/ACPI e ce ne erano due

events
events.ignore

con dentro i relativi file Defoult

dove devo andare a mettere mano?