PDA

Visualizza versione completa : problemi con Formula SE


forumant7
15-10-2005, 16.13.39
Scusate come posso far funzionare la seguente formula? ho visto che dopo l' 8° SE genera errore, ad es. se in A1 scrivo:
=SE(B8=1;"UNO";SE(B8=2;"DUE";SE(B8=3;"TRE";SE(B8=4;"QUATTRO";SE(B8=5;"CINQUE";SE(B8=6;"SEI";SE(B8=7;"SETTE";SE(B8=8;"OTTO";SE(B8=9;"NOVE";SE(B8=10;"dieci"))))))))))
Grazie e buon lavoro
Antonio
:confused:

Cricchia
15-10-2005, 21.42.54
Come riportato sulla guida in linea, il massimo di SE concatenati è pari a 7:

Limiti dei livelli di nidificazione
Una formula può contenere fino a sette livelli di funzioni nidificate.

è per quello che ricevi l'errore. In alternitiva dovresti/potresi usare una tabella di codifica insieme al CERCA.VERT ;)

forumant7
15-10-2005, 23.40.50
Cricchia, scusa la mia ignoranza ma sono agli albori con excel, potresti farmi un esempio pratico di applicazione CERCA.VERT
Grazie 1000 e un saluto
Antonio

Cricchia
16-10-2005, 13.45.23
ciao forumant7.. provo a spiegarmi (so già che farò un casino allucinante! :p)

Da quello che posso capire dalla tua formula, devi fare un controllo sulla cella B8 e scrivere il numero in cifre in base al valore contenuto.. giusto?!?
esistono in rete diverse funzioni libere e create da altri utenti, che fanno proprio questo.. prova a guardare qui:
http://www.terzaghi.it/excel/numeriinlettere.htm

se invece si tratta di pochi numeri o cmq devi associare qualcosa (che non siano solo numeri) in base al valore contenuto, puoi usare il cerca.vert come ti avevo scritto. ti faccio un esempio: in un altro foglio fai una tabellina del tipo:



A B

1 UNO
2 DUE
3 cane
4 gatto


insomma, scrivi a manina il corripondente di ogni valore.
poi sul foglio dove ci sono i valori usi il cerca.vert:

=CERCA.VERT(B8;Foglio2!A1:B4;2;0)

dove "Foglio2!A1:B4" è il range della tabella che hai scritto prima
in questo modo se in B8 c'è scritto "1" la forumla ti dà come risultato "UNO", se c'è scritto "4" ti dà "gatto".. insomma cerca nella tabella il corrispondente ;)

Mi sa tanto che al posto di chiarirti le idee, sono riuscita a confonderti.. :p

joey
16-10-2005, 18.00.20
Originariamente inviato da Cricchia
ciao forumant7.. provo a spiegarmi (so già che farò un casino allucinante! :p)

che strano... :p