PDA

Visualizza versione completa : [MDK] configurazione modem


SkAkKo
03-03-2005, 22.51.34
ciao a tutti!
ho dei problemi a configurare la connessione internet perch il modem non viene trovato.
ho un modem nortek usb 56k...su win la porta com3...su linux la porta com3 /dev/ttyS2 .... uso kppp imposto il dispositivo su questa porta poi faccio interroga modem e mi dice modem occupato...
provo a cambiare dispositivo e metto /dev/ttyS0 rifaccio interroga modem e qui mi dice modem pronto poi compare una finestra delle risposte del modem ati ati1 ati2 x sono vuote...cosa devo fare?? grazie :p

wolverin
04-03-2005, 10.19.42
e lascindo semplicemente /dev/modem?

Ma aspetta un attimo, su che porta ti connetti al pc: usb o parallela/seriale?

SkAkKo
04-03-2005, 12.23.15
se lascio /dev/modem mi dice impossibile accedere al modem
il modem collegato all' usb

SkAkKo
05-03-2005, 20.33.08
help me..come faccio a configurare la porta usb??

SkAkKo
09-03-2005, 20.31.12
dato che non riesco a configurare il mio modem usb .... sto provando con quello interno... sulla console digito il comando
cat /proc/pci e vedo che il mio modem riconosciuto... ma utilizzando sempre kppp e interroga modem mi dice modem assente..qualche consiglio?? tnx :p

SkAkKo
13-03-2005, 20.42.13
up

afterhours
13-03-2005, 20.48.38
ma il modem supportato???

pure io avevo un modem usb (di un'altra marca per) e mandrake non lo riconosceva...ho preso un seriale e l'ha riconosciuto subito :p

SkAkKo
13-03-2005, 21.09.05
non so...cmq ora sto provando a configurare quello interno :p ma neanche questo funza... e pure viene riconosciuto...

SkAkKo
24-09-2005, 15.41.57
raga rieccomi :p ... sono riuscito a trovare un modem seriale... come faccio a configurarlo? sulla porta com1..

Downloader
24-09-2005, 15.51.17
Originariamente inviato da SkAkKo
raga rieccomi :p ... sono riuscito a trovare un modem seriale... come faccio a configurarlo? sulla porta com1..

Prova ad usare KPPP e poi a cercare il canale adatto andando nell opzioni.

SkAkKo
24-09-2005, 16.16.39
ho provato... se metto su /dev/ttyS0 e faccio interroga modem mi dice modem pronto e compare una finestra con le risposte ati del modem per sono vuote... mentre /dev/ttyS1 e via mi dicono modem assente...

Ghandalf
24-09-2005, 17.41.24
Perche non provi a configurare a mano net.ppp0, in gentoo e' in /etc/conf.d/net.ppp0.
Il file e' veramente semplice, praticamente intuitivo, per avviare la connessione poi

/etc/init.d/net.ppp0 &

dipende ovviamente dove la distro che utilizzi mette gli script per l'avvio dei server..;)

Ti posto il mio net.ppp0, lo uso per una connessione via bluetooth con cell:


# /etc/conf.d/net.ppp0:
# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp/
#files/confd.ppp0,v 1.3 2005/02/06 09:22:13 mrness Exp $

# Config file for /etc/init.d/net.ppp0


PEER="wind" # Define peer (aka ISP)
DEBUG="no" # Turn on debugging
PERSIST="yes" # Redial after being dropped
ONDEMAND="yes" # Only bring the interface up on demand?
MODEMPORT="/dev/rfcomm0" # TTY device modem is connected to
LINESPEED="115200" # Speed pppd should try to connect at
INITSTRING="" # Extra init string for the modem
DEFROUTE="yes" # Must pppd set the default route?
HARDFLOWCTL="yes" # Use hardware flow control?
ESCAPECHARS="yes" # Use escape caracters ?
PPPOPTIONS="lock" # Extra options for pppd
USERNAME="********" # The PAP/CHAP username
PASSWORD="*******" # Your password/secret. Ugly I know, but i
# will work on something more secure later
# on. 700 permission on /etc/init.d/net.ppp0
# should be enouth for now.
NUMBER="4488" # The telephone number of your ISP
# leave blank for leased-line operation.
REMIP="" # The ip of the remote box if it should be set
NETMASK="" # Netmask
IPADDR="" # Our IP if we have a static one
MRU="768" # Sets the MRU
MTU="768" # Sets the MTU
RETRYTIMEOUT="600" # Retry timeout for when ONDEMAND="yes" or
# PERSIST="yes"
IDLETIMEOUT="600" # Idle timeout for when ONDEMAND="yes"
PEERDNS="yes" # Should pppd set the peer dns?

AUTOCFGFILES="yes" # By default this scripts will generate
# /etc/ppp/chat-isp, /etc/ppp/chap-secrets,
# /etc/ppp/pap-secrets and /etc/ppp/peers/isp
# automatically. Set to "no" if you experience
# problems, or need specialized scripts. You
# will have to create these files by hand then.

AUTOCHATSCRIPT="yes" # By default this script iwll generate
# /etc/ppp/chat-${PEER} automatically. Set to "no"
# if you experience problems, or need specialized
# scripts. You will have to create these files by
# hand then.


# Directory where the templates is stored
TEMPLATEDIR=/etc/ppp

SkAkKo
24-09-2005, 17.56.56
ok.. ci provo :p

SkAkKo
25-09-2005, 15.17.59
non sono riuscito a trovare il file... ho provato a cercare anche qualcosa di simile ma niente...

SkAkKo
25-09-2005, 17.32.56
evvai funziona... era l' alimentazione che non andava :p

Ghandalf
26-09-2005, 01.01.51
(Y)..:)
ma alla fine via kppp o via file di configurazione?

SkAkKo
26-09-2005, 01.22.17
kppp :p