PDA

Visualizza versione completa : [*BUNTU] Errore durante installazione apache su Ubuntu 4.10


gutguy
24-02-2005, 10.19.47
Ciao,
devo installare apache2 su Ubuntu.
Ho decompresso il file tar.gz ma quando lancio il comando ./configure mi da questo errore:

http://gutguy.altervista.org/immagini/apache.jpg

Successivamente ho tentato di lanciare il comando make, ma mi dice che nn lo trova.
Come posso fare?
Grazie.

Ghandalf
24-02-2005, 14.38.14
MA Ubuntu non è un derivato di Debian? Non puoi usare apt-get?

gutguy
24-02-2005, 14.47.22
Originariamente inviato da Ghandalf
MA Ubuntu non è un derivato di Debian? Non puoi usare apt-get?

Si hai ragione, ma devi scusarmi sono alquanto niubbo.
Cmq spesso quando devo installare pacchetti che scarico da internet (come i bnc per es.) nella procedura mi dice che devo compilare (per es. make ecc) e senza un compilatore nn riesco ad installarli.
Forse mi sbaglio, se tu mi dici che posso farne a meno di un compilatore ben venga.

Ghandalf
24-02-2005, 14.59.41
Puoi farne sicuramente a meno...dammi il tempo di documentarmi..;)

gutguy
24-02-2005, 16.28.55
Originariamente inviato da Ghandalf
Puoi farne sicuramente a meno...dammi il tempo di documentarmi..;)

Qui ti riporto la procedura di installazione di un bnc:




.: Psy/bnc Installazione :.
Niente di più semplice!
Una volta portato sulla shell il file psyBNC2.1.tar.gz eliminate il formato tar.gz con il comando:
tar -xzvf psyBNC2.1.tar.gz


Entriamo Nella Cartella e utilizziamo il comando "make" per compilare i file del Psy

Fatto questo, digita ./psybnc per lanciarlo in background. La porta di default è la 31337(da cambiare praticamente obbligatoriomanete in quanto nelle shell commerciali la porta 31337 è sicuramente già in uso)

Vedere Configurazione Psy per configurarlo

Magari te sai come procedere usando apt.
Grazie.

Ghandalf
24-02-2005, 16.44.28
ok...allora ubuntu è una debian per cui puoi utilizzare i tools debian per installare i pacchetti, a tal proposito controlla se c'e' un sistema (synaptic) da cui gestire l'installazione dinuovo software.

In ogni caso puoi utilizzare apt-get che dovrebbe essere presente già sul sistema.

Con pat-get configuri i repository dei pacchetti on line lui si occupa di risolvere le dipendenze, scaricare ed installare il software.

es.

# apt-get psybnc

dovrebbe installre tutto il necessario..;)
Ricorda che prima però devi configurarlo..;)

gutguy
24-02-2005, 20.45.13
ok, grazie per la risp.
Metti che abbia sul mio ubuntu già il pachetto psybnc.tar.gz a questo punto lo decomprimo o no?
E poi lancio apt-get psybnc?
Perchè ho provato e mi dice che nn trova nulla.
Sono alquanto confuso riguardo apt.

Ghandalf
26-02-2005, 02.13.32
cos'e' che non comprendi di apt-get?

gutguy
26-02-2005, 18.02.06
Originariamente inviato da Ghandalf
cos'e' che non comprendi di apt-get?

Devi scusare la mia niubbità.:rolleyes:
Il problema è che tutte le istruzioni per i programmi prevedono lo scompattamento del tar.gz e relativa compilazione.
Non riesco a capire come si procede per le installazioni.
Forse devo scompattare i tar.gz e lanciare apt-get nomeprogramma?

JMass
26-02-2005, 19.55.20
No, apt lavora in maniera completamente diversa e non si basa sui pacchetti tar.gz da compilare. Per imparare ad usare questo potente strumento ti rimando all'APT HOWTO (http://www.debian.org/doc/user-manuals#apt-howto), dal link puoi scaricarlo in italiano e in vari formati.