PDA

Visualizza versione completa : http://localhost non funziona


Mentos
20-10-2004, 12.42.07
Ho installato Apache, PHP e MySql sul mio pc e fin qui nessun problema.
Ho anche cominciato a creare una pagina (di cui ho chiesto info in un'altra discussione), ma purtroppo mi viene visualizzata soltanto se scrivo http://127.0.0.1/pagina.php.
Se metto localhost oppure il nome del mio pc non funziona. Se metto l'indirizzo ip del pc o 127.0.0.1 invece si. Ho letto qua e là su internet che "deve funzionare", per cui, armandomi di pazienza, ho disinstallato tutto e ho ricominciato da capo, ma il risultato è sempre lo stesso. Mi è stato detto che forse non avevo la porta 80 in ascolto, ho controllato e la porta ascolta eccome
Poi mi è stato detto che dovevo modificare il file di routing di windows (ah, uso Windows 2000), ma per evitare casotti non ho toccato niente.
In ufficio ci connettiamo ad internet tramite la lan e un proxy. La cosa strana è che il mio collega non ha problemi di questo tipo. Ho addirittura copiato i suoi files di configurazione di apache e php, cambiando soltanto il nome del pc all'interno del httpd.conf, ma niente, non funziona....
Qualcuno può aiutarmi????
:confused:

P8257 WebMaster
20-10-2004, 12.46.32
Edita il file "hosts" presente nella cartella di Windows (o in una delle sottocartelle di system32) ed aggiungi la seguente sintassi:


127.0.0.1 localhost


localhost verrà così risolto.

Bye :cool:

T.I.E.S applied.

This is 3k post!!!.

Dav82
20-10-2004, 14.47.13
Originariamente inviato da P8257 WebMaster
This is 3k post!!!.

'na bella birrozza ti ci vuole!

(B) (B) (B)

cipi
20-10-2004, 16.34.27
hai provato con localhost:8080 ??? Non basta quello?

P8257 WebMaster
20-10-2004, 17.02.20
Dav82 ha scritto:


'na bella birrozza ti ci vuole!

(B) (B) (B)

Ma certo ;) (B).. offro io !

Bye :cool:

LoryOne
20-10-2004, 17.12.32
Permeeeeeeeeeessssssssso !

(B) (B) (B) (B)

P8257 WebMaster
20-10-2004, 17.18.41
LoryOne ha scritto:
Permeeeeeeeeeessssssssso !

(B) (B) (B) (B)

Accccccccooooooooomodatiiii..

Il signore desidera? :)

Weiss / Lagher / Pilsner / Ambrata / Stout .... :D

Consumazione minima: 1 pinta.. ;)

Bye :cool:

Mentos
21-10-2004, 10.23.19
P8257 WebMaster ti ringrazio per il suggerimento ma c'è un problema...
Ho aperto in edit il file hosts e la riga che mi hai detto di inserire
127.0.0.1 localhost
c'è già...e mo??? che altro potrebbe essere??
c'entra qualcosa il file lmhosts?

P8257 WebMaster
21-10-2004, 10.46.57
Aggiungi quella riga anche in quel file, sempre con la medesima sintassi...


127.0.0.1 localhost


Per essere sicuro che venga risolto, prova a fare anche un ping...

Bye :cool:

Mentos
21-10-2004, 11.03.05
niente da fare...

questa è la risposta del browser all'indirizzo http://localhost/test
(test è la cartella in cui c'è la pagina index.php che ho creato)




ERRORE
La URL richiesta non può essere recuperata

----------------------------------------------------------------------
Mentre si cercava di recuperare la URL: /test

È avvenuto il seguente errore:

URL non valida
Alcuni aspetti dell'URL richiesta sono errati. Possibili problemi:

Protocollo d'accesso mancante o errato (dev'essere `http://' o simile)
Nome dell'host mancante
Errata doppia conversione di caratteri nell'URL-Path
Caratteri illegali nel nome dell'host; gli "underscores" ('_') non sono permessi

P8257 WebMaster
21-10-2004, 11.12.57
Sembra che l'url non venga passata correttamente al server .. prova a guardare nelle opzioni del browser per verificare che le url vengano passate in utf-8

Bye :cool:

Mentos
21-10-2004, 12.07.16
anche questa opzione è cliccata nelle proprietà del browser...
Sto disperando di riuscire a risolvere il problema :(

La cosa strana è che il mio collega ha la stessa mia configurazione ma soltanto (ovviamente) ip e nome pc diversi dal mio

P8257 WebMaster
21-10-2004, 12.32.29
Ma se pinghi localhost, funziona?

Bye :cool:

Mentos
21-10-2004, 13.04.46
si, se pingo funziona e mi restituisce l'ip 127.0.0.1 e il nome del mio pc localhost...
ma che diavolo può essere????? :confused: