PDA

Visualizza versione completa : W2k SP4 - Impossibile disconnettere le connessioni di rete


Xtefano
07-05-2004, 10.39.14
Detta così fa ridere, vero ? A me un pò meno .... :grrr:

Cronistoria: un banalissimo batch schedulato di notte (come Administrator) fa (semplifico)
* net use K: /d
* net use K: \\server\share pwd /USER:domain\username
* ... elaborazioni e verifiche sui dati in K:
* net use K: /d

Per un mio errore :wall: :wall: :rolleyes: nelle "elaborazioni e verifiche" si è skiantato senza eliminare le connessioni di rete (che in realtà sono 3).

Ora mi ritrovo con:
* Gestione Risorse che mi mostra le unità H: K: I: presenti con la magnifica X rossa
* NET USE che recita "non ci sono voci nell'elenco"
* se tento di fare NET USE /D o "disconnetti" da GUI ottengo un bel "Impossibile trovare la connessione di rete"
* se tento di accedere alle unità ho "errore, utente sconosciuto o pwd non valida"

E' qc di molto simile all'articolo 811518 (http://support.microsoft.com/default.aspx?scid=kb;en-us;831518) della KB Microsoft...

Andrei anche "sparato" nel registry a cancellare a mano le info, ma si tratta di un server "delicato" su cui lavorano oltre 100 persone e non vorrei finire crocifisso in sala mensa ... [(c) P.Villaggio, 1975]


Qualche idea ??


1k grazie in anticipo (o MTIA per gli anglofili)


Byez

Stefano

Gianluca72
07-05-2004, 10.46.08
Hai provato a fare un semplice riavvio in "last know good configuration"?

Xtefano
07-05-2004, 10.56.53
Grazie per la risposta, ma il riavvio (noto anche come "esci e rientra") è al primo posto nelle FAQ di qualsiasi informatico degno di questo nome...... ;)
Il problema è che non posso riavviare il server perchè ci lavorano in tanti anche da sedi remote, dovrei attendere domenica notte (c'è il reboot schedulato) ..... e vedere l'effetto che fa [(c) E.Jannacci, 197?] sperando in bene. In questo caso però mi perderei l'elaborazione di questa notte che, dopo le 2 precedenti perse, diventa quasi indispensabile ....


Byez

Stefano

Xtefano
07-05-2004, 12.03.03
Niente, eh ?? :(

Nel frattempo ho "googlato" (Y) un pò ed ho trovato:
Mapping Netware Drives with the AT Scheduler (http://support.microsoft.com/default.aspx?scid=http://support.microsoft.com:80/support/kb/articles/Q130/6/68.asp&NoWebContent=1) - è riferito a Netware e NT, ma è esattamente quello che succede ..... dice di fare reboot :rolleyes: o stoppare il servizio Workstation

AT Jobs su SecurityBugware (http://www.securitybugware.org/NT/1046.html) - si riferisce all'articolo della KB, ma non dà soluzioni (articolo poi rivisto anche su altri siti)

Unable to Remove Network Connection Created by AT Scheduler (146110) (http://www.it-faq.pl/mskb/146/110.HTM) - la soluzione che riporta non è applicabile al mio caso (provata, non funziona)


Byez

Stefano

Gianluca72
07-05-2004, 12.33.42
nell' articolo da tè riportato:

RESOLUTION
The scheduled command or batch file that establishes the connection should also terminate that connection by adding a NET USE <drive> /DELETE command to the end of the file. The drive will be unusable for any other application or process until the system is restarted if the drive is not disconnected by the originating process.


:mad: mi dispiace ma penso propio che il riavvio sia necessario :crying:

P.S.: compli x le citazioni comiche, veramente simpatiche :D

Xtefano
11-05-2004, 18.46.44
Aggiornamento, anche se tardivo ...


CVD il reboot ha sortito l'effetto desiderato...


Grazie cmq a chiunque ci ha fatto almeno un pensierino per tentare la risposta ...



Byez

Stefano