PDA

Visualizza versione completa : Kernel 2.4.8-26


Sanduleak
19-09-2003, 17.13.00
Salve a tutti!
Per installare un driver per il modem ADSL (SpeedWeb USB) avrei bisogno del suddetto kernel, il 2.4.8-26, per RedHat 9.0.
Vi dico innanzitutto cosa ho provato:
il driver è un modulo da installare con insmod.
Ho provato innanzitutto a forzarlo con l'opzione -f sul kernel 2.4.22 che c'è in RH 9, ma mi dice che non trova una chiamata (potrei essere + preciso lo so.. ma al momento non ho sottomano linux).
Ho provato a scaricare, compilare e installare il 2.4.8, il sistema bootava (con qualche problemuccio di dipendenze, ma si avviava, anche con X), e con insmod mi diceva che ci voleva il 2.4.8-26, non il 2.4.8 normale. Ho provato anche qui il -f ma mi dava lo stesso identico errore che sull'altro kernel. Ho provato quindi con un kernel 2.4.8-26 preso da Mandrake 8.1, ma al momento del boot mi dava Kernel Panic: impossibile trovare l'init.
Provando invece ad installare quel Kernel sulla Mandrake 8.0 il driver funzionava benissimo.. peccato che Mandrake 8.0 non sia proprio il mio ideale di distro (non funzionano parecchie cose, e oltretutto è un po' vecchiotta ormai).
A questo punto come faccio a installare sto benedetto driver? il Kernel 2.4.8-26 se ho capito bene è il 2.4.8 (che già ho) con 26 patch applicate... dove le trovo eventualmente?? Raga sono nelle vostre mani!:p
p.s.:non ditemi di farmi cambiare il modem.. purtroppo sono con Alice e il modem è della telecom.. e voi tutti conoscete la proverbiale velocità della suddetta ditta nel provvedere(N) (N) (N) ho già chiesto il cambio del modem ma chissà se e quando se ne parla (W)

pholcus
19-09-2003, 17.49.53
Il kernel 2.4.8 e' moooolto vecchio..te lo sconsiglio vivamente..

Si potrebbe provare un trucchetto, ma nn me ne assumo la responsabilita'.

Prendi i sorgenti dell'ultimo kernel disponibile. Ricompilalo modificando pero' il Makefile in modo che nelle prime righe dove si puo settare la versione sia cosi:

VERSION = 2
PATCHLEVEL = 4
SUBLEVEL = 8
EXTRAVERSION = -26

installalo e poi vedi riesci a caricare il modulo del modem..

Ciao

Sanduleak
19-09-2003, 17.55.22
questa è cosa molto buona O_O tnx proverò sia con l'ultimo.. ma sopratutto col 2.4.8 senza il 26..
so che il 2.4.8 è molto vecchio ma che ce posso fa?? :(

Manlio
19-09-2003, 22.59.39
perché con il 2.4.8? dove hai scaricato il modulo? verificato se il tuo modem non ha i driver integrati nell'ultima versione del kernel?

P.S. mi permetti una minuscola precisazione? sotto linux insmod non installa i moduli, li carica per il loro utilizzo (insert module)... ciò significa che il modulo deve essere stato compilato assieme al kernel... cmq i nuovi kernel permettono anche il caricamento di moduli compilati con diverse versioni di kernel

ALLA FINE: con il kernel originale RedHat prova a caricare quel modulo... (Y)

Sanduleak
19-09-2003, 23.03.09
è un precompilato...
http://www.ipmdatacom.it/download/adsl-usb-ita.htm
il mio è il primo dei 2.
ho già provato con l'originale, anche con l'opzione -f