PDA

Visualizza versione completa : Knoppix 3.2 problema volumi fat e ntfs


davlak
11-07-2003, 12.30.51
Salve, ho installato Knoppix 3.2 su HD.
Ho XP come prima partizione su NTFS (hda1)
Knoppix hda5 (4 giga) su ext3
swap hda6

sull'altro HD ho

Swap XP hdb5 (2 giga) FAT32
Dati hdb6 (78 giga) FAT32

Ho creato tre cartelle in /mnt: Win_XP - Swap - Dati
Faccio il mount da root:

mount -t vfat /dev/hdb5 /mnt/Swap

mount -t vfat /dev/hdbs /mnt/Dati

mount -t ntfs /dev/hda1 /mnt/Win_XP

tutto ok, vedo la partizione di XP in lettura e le due fat in lettura - scrittura.

Riavvio e spariscono.

Perchè? :confused:

Grazie :)

wolverin
11-07-2003, 12.35.03
Perché le devi inserire all'interno del file fstab che trovi sempre all'interno della directory etc, allora te le monta in automatico all'avvio.

La riga che devi inserire ha una struttura di questo tipo:

/dev/hdaX /mnt/dati vfat defaults 0 0

ciao

mzs84
11-07-2003, 12.35.16
E' normale, nelle partizioni NTFS per adesso si può accedere in sola lettura. C'è già il supporto per la scrittura, ma è pericolosissimo, si possono anche perdere tutti i dati in quella partizione.
Cosa intendi dire per "riavvio e spariscono"? Che spariscono le cartelle o il contenuto? Nel secondo caso è tutto nella norma, basta rimontarle.

EDIT: Ops.. mi hai anticipato di qualche secondo :rolleyes:

davlak
11-07-2003, 12.41.49
Originariamente inviato da wolverin
Perché le devi inserire all'interno del file fstab che trovi sempre all'interno della directory etc, allora te le monta in automatico all'avvio.

La riga che devi inserire ha una struttura di questo tipo:

/dev/hdaX /mnt/dati vfat defaults 0 0

ciao

ecco il mio fstab:

# /etc/fstab: filesystem table.
#
# filesystem mountpoint type options dump pass
/dev/hda5 / ext3 defaults,errors=remount-ro 0 1
/dev/hda6 none swap sw 0 0
proc /proc proc defaults 0 0
/dev/fd0 /floppy vfat defaults,user,noauto,showexec,umask=022 0 0
/dev/cdrom /cdrom iso9660 defaults,ro,user,noexec,noauto 0 0
# partitions found by Knoppix
#/dev/hda1 /mnt/hda1 ntfs noauto,users,exec,ro,uid=knoppix,gid=knoppix 0 0
#/dev/hdb5 /mnt/hdb5 vfat noauto,users,exec,umask=000,uid=knoppix,gid=knoppi x 0 0
#/dev/hdb6 /mnt/hdb6 vfat noauto,users,exec,umask=000,uid=knoppix,gid=knoppi x 0 0

cioè, in pratica devo sostituire solo ai vari hdXY > Swap > Dati > Win_XP

Giusto? :)

wolverin
11-07-2003, 12.49.51
Si, inoltre togli i cancelletti all'inizio delle righe che interessano i vari dispositivi che devi montare. L'unica cosa è la parte finale "umask=000,uid=knoppix,gid=knoppi" non l'avevo mai vista, comuqnue lasciala e prova a riavviare.

Comunque, sicuramente l'hai già fatto, prima di modificare l'fstab fanne una copia.


ciao

davlak
11-07-2003, 13.33.23
Dopo un pò di tentativi a vuoto ho risolto così:

# /etc/fstab: filesystem table.
#
# filesystem mountpoint type options dump pass
/dev/hda5 / ext3 defaults,errors=remount-ro 0 1
/dev/hda6 none swap sw 0 0
proc /proc proc defaults 0 0
/dev/fd0 /floppy vfat defaults,user,noauto,showexec,umask=022 0 0
/dev/cdrom /cdrom iso9660 defaults,ro,user,noexec,noauto 0 0
# partitions found by Knoppix
/dev/hda1 /mnt/Win_XP ntfs auto,users,exec,ro,uid=knoppix,gid=knoppix 0 0
/dev/hdb5 /mnt/Swap vfat auto,users,exec,umask=000,uid=knoppix,gid=knoppix 0 0
/dev/hdb6 /mnt/Dati vfat auto,users,exec,umask=000,uid=knoppix,gid=knoppix 0 0

ho dovuto togliere il no davanti a auto...sennò non faceva il mount automatico in riavvio.

grazie! :)

wolverin
11-07-2003, 13.42.44
Scusa della segnalazione imprecisa, ma anch'io l'ho imparato da solo e con qualche imprecazione.


ciao

davlak
11-07-2003, 15.49.40
figurati, no prb. :)

resta il fatto che non so perchè, ma la DATI non me la trovo dopo il riavvio, le altre si...strano perchè mi sembra tutto corretto, e poi é una fat, invece Win_XP che é NTFS, c'é sempre.

:confused:

JMass
11-07-2003, 16.13.35
Togli auto, basta users,exec,umask=000