PDA

Visualizza versione completa : Apache & Php: Help me !!!


Federik
06-06-2002, 19.07.29
La mia distro linux č la Mandrake 8.2,

sto cercando di configurare il web server Apache, con supporto per il Php.

Una volta scaricati i file per Apache e Php, ovvero:

httpd-2.0.36.tar.gz & php-4.2.1.tar.gz,

eseguo i seguenti comandi:

gunzip php-4.2.1.tar.gz,
tar php-4.2.1.tar,

gunzip httpd-2.0.36.tar.gz,
tar httpd-2.0.36.tar,

Fin qui ovviamente tutto bene.

Quindi, eseguo i seguenti comandi:

nella cartella di apache,
./configure -prefix="path/in cui voglio installare apache",

e va tutto bene.

Dopo,
nella cartella del php,
./configure -with-apache="path dei sorgenti di apache" -enable-track-vars-prefix=path in cui voglio installare php,

e adesso sono guai,
:confused: :confused: :confused:

mi appare il seguente messaggio:

"You will need bison if you want to regenerate the PHP parsers."

Che posso fare ????

Grazie dell'aiuto.

Ibanez
06-06-2002, 19.16.40
Se hai la mandrake 8.2, sia apache che php sono incluse nella distro. Usa un prog tipo mandrake update e installali da lė, configura praticamente tutto da solo( certo se non hai pčarticolari esigenze).

Marko
06-06-2002, 19.30.14
Originariamente inviato da Ibanez
Se hai la mandrake 8.2, sia apache che php sono incluse nella distro. Usa un prog tipo mandrake update e installali da lė, configura praticamente tutto da solo( certo se non hai pčarticolari esigenze).

Infatti, con mdk c'č il software manager.
Basta che cerchi apache e apache php mod o qualcosa del genere (se cerchi solo apache ti trova apache e tutti i moduli), dai l'installazione.
Lui ti chiederā di inserire il cd e cosė si installa e ce l'hai funzionante.