PDA

Visualizza versione completa : Excel - Somma_se con int_somma in forma di matrice


omancino
22-04-2016, 11.14.30
Buongiorno a tutti. Non so se si tratti di una banalità, ma nel caso in cui il parametro int_somma della funzione Somma_se non sia relativo ad una sola colonna (es. C1:C4) ma ad una matrice di celle (es. C1:E4), il risultato tiene conto solo dei valori nella prima colonna della matrice (sono sommati i valori C1:C4).
Allego un Excel di esempio.
Dove è l'errore?
Grazie

xilo76
22-04-2016, 15.30.28
Così?:

http://i65.tinypic.com/33ejtzd.jpg

colonne originali Colonna calcolata
pippo 10.00 10.00 20.00 pippo
pluto 30.00 30.00 0.00
pippo 50.00 50.00 100.00 G2: =IF(A2=$H$2,B2+C2)
G3: =IF(A3=$H$2,B3+C3)
G4: =IF(A4=$H$2,B4+C4)

omancino
22-04-2016, 16.58.39
Grazie Xilo76. In realtà avrei bisogno che in G2 ci fosse la somma (B2+B4+C2+C4) cioè dei 4 valori relativi a pippo nelle "colonne originali".
La mia somma_se originale mi da' solo (B2+B4).

xilo76
22-04-2016, 21.46.17
Cioè dovrebbe dare 180 nella prima e nell'ultima casella?

Alexsandra
23-04-2016, 09.38.03
in G2 metti questa formula

=SOMMA.SE(A2:A4; H2; B2:B4)+SOMMA.SE(A2:A4; H2; C2:C4)

omancino
26-04-2016, 08.36.49
Grazie Alexsandra. In effetti è una soluzione efficace. Mi ero incaponito nel cercare una singola funzione.
:Oh-yea:

LoryOne
26-04-2016, 12.16.08
Cerca in rete MATR.SOMMA.PRODOTTO

omancino
26-04-2016, 15.33.47
LoryOne ho cercato la funzione e ne ho studiato l'applicazione, ma mi rimane complesso capirne l'aggancio al mio quesito.
Avresti qualche input?
Grazie.