PDA

Visualizza versione completa : activation link BROKEN


walker1
08-10-2015, 21.30.31
Ciao,
ho ricevuto un link di attivazione per un forum ma il link contiene qualche errore, tipo %20 anziche' % o cose del genere.
Sapete correggerlo ?
Eccolo:
http://pastebin.com/gft9LpJg

oppure:
https://www.switchboardfree.co.uk/activateAccount.aspx?email=3Dwalker@20mail.it&acc=3D38B45E9B-271B-456C-8474-=843EE7962CF9&rid=3D1&utm_source=3Dactivation%20link%20email&u=tm_medium=3Demail&utm_campaign=3Dauto%20email

LoryOne
09-10-2015, 10.07.39
Un link URL non può contenere spazi, es: http://www.a b.html
E' per questo motivo che allo spazio si sostituisce %20, ossia 32 (Codice ASCII) in decimale.
Pertanto, http://www.a%20b.html
Il link è molto probabile che non contenga alcun errore, ma sia il tuo client di posta, nella sua visualizzazione mail in html, che non sia predisposto per identificare correttamente il link e consentirti di aprire il browser su quell'url. ;)
Porta il mouse sul primo mio link e poi sul secondo...La noti la differenza ?
Copia ed incolla l'url da te postato direttamente nel browser...al 99% funziona, ma pure lui potrebbe essere impostato per postare correttamente al server l'url richiesto.

tof63
09-10-2015, 12.59.44
Solitamente qui link sono validi solamente per poco tempo.
E' possibile che se, ad esempio, hai fatto la registrazione ieri sera e hai aspettato questa mattina a cliccare sul link della mail, il link non sia più valido perchè scaduto.

walker1
10-10-2015, 09.12.10
mi hanno rispedito il link di attivazione ma la mia email temporanea (/view.aspx) non lo visualizza proprio perche' visualizza i messaggi in .aspx e l'email che ho ricevuto e' in .html

Allora ho copiato il codice sorgente del messaggio ricevuto con il link di attivazione della webmail temporanea e tale codice e' questo qui sotto in rosso ma lo riassumo io in 2 righe qua:

href=3D

https://w=
ww.switchboardfree.co.uk/?rid=3D%RID%&utm_source=3Dactivation%20link%20emai=
l&utm_medium=3Demail&utm_campaign=3Dauto%20email

href=3D"https://www.switchboardfree.co.uk/a=
ctivateAccount.aspx?email=3Dwalker@20mail.it&acc=3D38B45E9B-271B-456C-8474-=
843EE7962CF9 &rid=3D1&utm_source=3Dactivation%20link%20email&u=
tm_medium=3Demail&utm_campaign=3Dauto%20email

borgata
10-10-2015, 10.01.26
Racchiudi il "codice sorgente" tra tag CODE, così rende illeggibile il topic.

walker1
10-10-2015, 11.03.23
grazie di tutto ma sono gia riuscito a correggerlo.
Biosgnava sostituire 3D con = e poi bisognava togliere %20.