PDA

Visualizza versione completa : Cambiare Set Caratteri Internet Explorer 6 e7


AMIGA
12-09-2011, 01.17.41
Mi è capitato su un PC, che dopo aver digitato l'apostrofo ', su un articolo postato su portale aziendale, nel rivederlo dopo la pubblicazione, mi ritrovo al posto dell'apostofo la lettera &, il problema è solo su quel PC e solo con Internet Explorer 6 e 7.Sullo stesso PC, con altri Browser, come Firefox il problema non sussiste, preciso anche che Internet Explore genera lo stesso problema anche con altri utenti, quindi credo che il problema carattere sia legato ad un settaggio generale del browser di casa Microsoft, che al momento mi sfugge.Ho provato a disinstallare IE 7 e a installarlo exnovo, ho anche provato a resettarlo, ma il problema rimane.

borgata
12-09-2011, 09.15.43
Non vorrei dire una vaccata, ma sei sicuro che non sia un semplice problema di obsolescenza del browser, incapace di interpretare correttamente i caratteri speciali?

Ricordo che ai tempi di ie6 i programmi per pubblicare pagine sul web sostituivano per compatibilità i caratteri speciali, per esempio & diventava &amp:
Qui (http://www.w3schools.com/tags/ref_entities.asp) una tabella (dove però specifica che l'apostrofo così inserito non funziona in IE :p ).

AMIGA
12-09-2011, 19.41.55
Il fatto è che solo in quel PC succede, che ha WinXP SP2 IE 6 anche aggiornato a IE 7, su altri PC con lo stesso OS e internet Explorer 6, il problema non sussiste, non solo, loro non vedono l'errore, ma vedono il giusto apostrofo digitato.

borgata
12-09-2011, 19.53.15
ok, è un problema del pc.

Hai verificato che la codifica dei caratteri sia corretta? (pannello di controllo -> opzioni internazionali e della lingua e dalle opzioni di ie -> visualizza -> codifica)

ma soprattutto... che ci fai con ancora ie6 e ie7 su quel pc? :p

AMIGA
12-09-2011, 22.46.26
ok, è un problema del pc.

Hai verificato che la codifica dei caratteri sia corretta? (pannello di controllo -> opzioni internazionali e della lingua e dalle opzioni di ie -> visualizza -> codifica)

ma soprattutto... che ci fai con ancora ie6 e ie7 su quel pc? :p
Sono PC che devono lavorare con programmi aziendali, che sono incompatibili con IE8 e OS superiori a XP per il momento, su questo PC ho rimediato con Firefox, ma l'utente vorrebbe riutilizzare IE, sicuramente è una cavolata, prima o poi troverò la soluzione.

borgata
12-09-2011, 23.23.08
Di all'utente che è un'ottima occasione per passare ad un browser migliore, dato che internet explorer su xp non è più supportato. :p

Hai comunque verificato quelle due impostazioni?

AMIGA
12-09-2011, 23.43.27
Di all'utente che è un'ottima occasione per passare ad un browser migliore, dato che internet explorer su xp non è più supportato. :p

Hai comunque verificato quelle due impostazioni?
Domani quando vado in servizio, faccio la prova, i programmi che utilizziamo hanno un ritmo più lento, anche se aggiornati frequentemente, devono anche adeguarsi alle nuove prospettive.Quasi tutti i programmi e portali Intranet, li ho fatti girare su Win7 e nuovi Browser, ma il CED ne sconsiglia l'utilizzo per il momento, fino a quando non saranno ufficialmente supportati, l'utente non deve scegliere, sono io che devo attenermi ai requisiti richiesti dai programmi, Firefox comunque è l'alternativa che risolve sempre.

AMIGA
21-09-2011, 20.13.14
ok, è un problema del pc.

Hai verificato che la codifica dei caratteri sia corretta? (pannello di controllo -> opzioni internazionali e della lingua e dalle opzioni di ie -> visualizza -> codifica)

I settaggio sono a posto, il problema è altrove !