PDA

Visualizza versione completa : [Apache/PHP] Problema con l'integrazione


UG0_BOSS
05-08-2006, 19.36.52
Oggi ho deciso di installare Apache PHP e MySql per creare un database personale. Per l'installazione ho seguito questa guida:
http://www.phpnews.it/articoli/php/installare-apache-2-php-5-mysql-4.1-su-windows/2/

Dopo aver installato Apache server 2.2.3 e scompattato PHP nella cartella C:/PHP/, spostato php5ts.dll in C:\WINDOWS, modificato httpd.conf e rinominato php.ini.

Quando si tratta di riavviare Apache mi compare questo errore:
"
HTTPD.EXE: syntax error on line 116 of (percorso del file httpd.conf di apache): Cannot load C:\PHP\php5apache2.dll into server: Impossibile trovare il modulo specificato.
"

Cosa potrebbe essere? in C:\PHP c'Ŕ il file php5apache2! forse Apache Ŕ una versione troppo recente? mi sembra strano perchŔ li ho scaricati entrambi oggi... aspetto le vostre illuminazioni :)

Semi.genius
06-08-2006, 00.01.24
Un consiglio per evitare rompicapi...ti conviene installare una versione di Apache con giÓ incluso il modulo di Php stile AppServ o Server2Go. o hai necessitÓ di fare te tutto passo per passo?

Downloader
06-08-2006, 00.05.05
Oppure c'Ŕ anche EasyPHP.

Io sinceramente preferisco far tutto passo passo perchŔ a scuola molti miei compagni hanno avuto problemi con questi pacchetti.

Semi.genius
06-08-2006, 00.07.43
Oppure c'Ŕ anche EasyPHP.
Io sinceramente preferisco far tutto passo passo perchŔ a scuola molti miei compagni hanno avuto problemi con questi pacchetti.

Io ho avuto invece il problema inverso:p

UG0_BOSS
06-08-2006, 00.18.06
Boh.. allora adesso provo a disinstallare il tutto e ad installare il pacchetto.. poi vi dico com'Ŕ andata

espiritos
08-08-2006, 13.45.19
E' successo anche a me. Sembra che ci siano problemi con Apache 2.2 e Php. Io usando questa nuova versione di php ho risolto http://snaps.php.net/win32/php5.2-win32-latest.zip
e al posto di usare il file php5apache2.dll devi usare il file php5apache2_2.dll
Quindi nel file httpd.conf ci andrÓ questa istruzione:
LoadModule php5_module "C:/php/php5apache2.dll"

Ciao

UG0_BOSS
08-08-2006, 14.30.08
beh alla fine Ŕ andata tutto bene.. easy php Ŕ molto easy :p e quindi non ci sono stati problemi.

Tanto io non devo fare una cosa perfetta, mi basta la base appena sufficiente per realizzare e utilizzare questo piccolo database.