PDA

Visualizza versione completa : [DW] Dreamweaver, alterazione codice HTML


Lionsquid
30-01-2006, 12.38.01
ciao a tutti..

mi trovo davanti un problema a cui non so dare una soluzione perchè non conosco il sw Dreamweaver 8 (ho usato solo la v. 4 tempo fà)

in pratica nel tentativo di automatizzare dei cambi di codice (ho sempre usato Emeditor oppure PSPad) il DW8 mi legge male il codice e quando opero modifiche e dò salva mi IMMETTE questi errori di lettura

tale errore è un / poco prima del carattere > di chiusura del TAG

risultato.. prima di accorgermene ho inguaiato un bel pò di file

http://img82.imageshack.us/img82/1651/dw85qg.th.jpg (http://img82.imageshack.us/my.php?image=dw85qg.jpg)

guardate invece come si vede il codice con PSPAD (o emeditor, o notepad)


http://img64.imageshack.us/img64/8937/pspad8sj.th.jpg (http://img64.imageshack.us/my.php?image=pspad8sj.jpg)

probabilmente dipenderà da qualche setting di DW, ma dato che enormemente cambiato dalla v. 4...(mettiamoci anche 4 anni di NON uso)...

come risolvo il problema???


thx 1000 :)

Sergio Neddi
30-01-2006, 21.30.12
Mah, di solito i programmi per editare pagine web s'incasinano con pagine non scritte da loro, per cui è da evitare il fare modifiche al di fuori del programma stesso.
Giusto per capirci qualcosa di più, com'era il tutto prima della modifica? Insomma, cos'è stato cambiato automaticamente?
Comunque a me da idea che s'incasini con le virgolette, le righe ne sono piene e probabilmente perde la testa.

Lionsquid
30-01-2006, 22.32.48
no.. le virgolette sono necessarie.. è lo standard.. il casino l'ha crato il dw8 che aveva attivato (e non ho idea come dato che non era la mia macchina) un setting tra le preferenze che automaticamente estendeva la validazione/compatibilità allo standard XHTML immettendo il carattere /

hai fini del funzionamento della pagina non è nulla di grave... ma in quel momento mi è sembrata una catastrofe poiché avevo già sfruttato la possibilità di sostituzione di ampie porzioni di codice in maniera automatizzata. In un successivo controllo con un editor testuale puro... mi è crollato il mondo addosso :S

ovviamente con quel carattere e utilizzando gli strumenti di validazione di FFox (Tidy HTML validator e/o il CSE HTML av. lite) errori a tonnellate!!

ritornato sulla macchina con il DW8 ho smanettato sulle preferences, ed ho distattivato tutto ciò che riguarda l'XHTML (dato che le pagine da aggiornare sono in solo HTML) e le cose si sono messe a posto...

adesso completo l'eliminazione manuale di quei famigerati "/"