PDA

Visualizza versione completa : pagefile.sys


Carlo Casadio
30-12-2004, 23.54.29
Aiuto! Ho perso una partizione, non sembra neanche come formattata.
S.O. Win XP PRO Service Pack 1

Premessa: da un po di tempo alla accensione sempre mi diceve in pagina blu che necessitava di una scansione in C: e talvolta in altre partizioni sempre dopo regolare spegnimento.
Oggi alla ennesima scansione il tempo è stato di circa 20 minuti con vari errori tra cui Cluster danneggiati su \pagefile.sys, poi sembra tutto normale però quando chiedo di vedere con "risorse del computer"
disco R (che ha ha cambiato il suo nome in Disco Locale) mi chiede se voglio formattarlo.
Non ho più eseguito operazioni che possono scrivere il disco rigido e ho timore a spegnere per non peggiorare la situazione.

Aiuto! Riesco a recuperare i dati?
Siamo allo inizio della rottura del disco rigido??

Grazie anticipatamente oltre agli auguri di Buon Anno.

Carlo

mao
04-01-2005, 13.52.04
comincia con lo spostare il disco su un pc funzionante e salvati i dati che ti servono. Temo che l'ora del tuo hd sia giunta

Carlo Casadio
04-01-2005, 14.31.47
Grazie MAO per la tua risposta, ma io non ricevendo risposte mi sono mosso.
Sullo stesso PC ho un'altro disco con ME commutabile da bios e non in rete per problemi di driver della scheda wireless (o miei di installazione). Fatto sta che di qui vedo e lavoro tranquillamente anche su quella partizione. Mentre il Sys info di XP la vede, dichiara che è integra, ma non formattata.
Punto attuale delle mie esperienze: quello che si è rovinato e proprio pagefile.sys di WIN XP e solo quello. Per ora non ho trovato maniera, dopo diverse prove di recuperarlo, non avendo fatto "gost" del disco rigido(MAXTOR 120GB), che però fin'ora continua a funzionare e tutti i controlli anche da DOS me lo danno integro.
Non voglio formattare ho troppi programmi e configurazioni personali da montare. Spero di trovare soluzione.

Ancora grazie.

Carlo

mao
04-01-2005, 14.36.13
allora prova a cancellare il file di swap da WInME e vedi se XP lo ricrea senza problemi

Carlo Casadio
04-01-2005, 14.46.14
Mai fatto, dove lo trovo?
Grazie

Carlo

mao
04-01-2005, 15.39.08
Se rendi visibili i file nascosti e di sistema sotto winME poi vai a cercarei il file pagefile.sys (che è il file di swap) nella partizione in cui hai WinXP e lo cancelli, dovresti riuscirci.
poi da windows XP puoi anche dirgli di spostare questo file in un'altra partizione o in un altro disco, e vedere di recuperare quella partizione malandata... però facciamo le cose per gradi.

mi dici come hai impostato i dischi e le partizioni?

Carlo Casadio
04-01-2005, 22.54.04
Per motivi di lavoro sono stato via. Appena possibile ho fatto, per impazienza,come mi hai indicato,da ME ho spostato e cancellato per due volte PAGEFILE.SYY,ma all'avvio winXP lo richea uguale (stessi byte = 323.216 Kb) e vede la partizione incriminatada come disco rimovibile non formattato.

Procedendo per gradi:
MAXTOR 120 GB
Partizione primaria: 27 GB Installato XP pro (partente dal 10/2003)
Partizione secondaria: 90 GB: Partizione 1: 30 GB
Partizione 2: 20 GB
Partizione 3: 20 GB
Partizione 4: 20 GB (Questa è sparita
con XP e funziona
con ME)
IBM 40 GB
Partizione primaria: 15 GB Installato Win ME (partente dal 08/2001)
Patizione secondaria: 25GB: Partizione 1: 5 GB
Partizione 2: 10 GB
Partizione 3: 10 GB
Nessuna partizione NTFS e la selezione avviene dal BIOS con disco 0 IBM e disco 1 MAXTOR.
Zpero di essere stato chiaro e di aver risposto a quello che mi chiedevi, mentre continuo a ringraziarTi per l'aiuto.

Carlo

mao
05-01-2005, 11.13.35
riesci a spostare i dati di quella partizione e ridistribuirli tra le altre, in modo da poterla riformattare, magari con partition magic, e vedere che succede? forse potrebbe essere una soluzione

Carlo Casadio
05-01-2005, 23.53.46
Ho controllato il registo, i file information, ecc.,insomma dappertutto, o almeno in un mucchio di posti, ho provato a riscrivere le condizioni di avvio, ma niente è cambiato, XP mi dice disco non formattato. Anch'io stavo pensando alla tua soluzione MAO, ma ciò che intriga è non capire come restaurarlo che secondo la mia esperienza è la prima mossa per capire l'origine dell'errore, a questo punto dopo tanto tempo e controlli chiaramente di SO e non di disco.
Comunque continuo a lavorare e aggiornerò qui i risultati. Nella continua speranza di venirne a capo sapendo la ragione.
A presto.

Carlo