PDA

Visualizza versione completa : Riempiremento celle Excel fino a raggiungimento numero


ghisirds
09-07-2007, 16.00.31
Salve.
Ho un foglio fatto così:
_________A___________B__________C__________D______ ____E
7___________________casa______grande______rossa___ ____verde
13_______10__________?
14_______20__________?
15_______30__________?
16_______40__________?
17_______50__________?

Praticamente nella celle B7, C7, D7, E7 ci sono inserite delle parole, che possono anche essere delle frasi.
Nella colonna A in A13, A14, A15 A16 e A17 ci sono invece dei numeri che rappresentano delle lunghezze.

Ora, dove ci sono i punti di domanda ?, io devo inserire una formula che mi concateni le varie parole o frasi della riga 7 fino al raggiungimento della lunghezza della colonna A (magari aggiungendo uno spazio ogni volta che inserisce il valore di una cella diversa)

Quindi in B13 comparira "casa" perchè sono già 4 caratteri, quindi minore di 10
In B14 invece ci sarà "casa grande rossa" che sono 17 caratteri, quindi minore di 20 e così via.

In B15, B16 e B17 ci sarà "casa grande rossa verde" che sono 23 caratteri quindi minore rispettivamente di 30, 40 e 50.

Non dovrebbe essere difficile, ma io non ci salto fuori!
Grazie a chiunque mi aiuterà

--
Righetto Fabrizio opera con le macchine taglio plasma (http://www.righettofabrizio.com/) per CNC

Alexsandra
09-07-2007, 22.52.35
serve una macro.
posta un file di esempio con dei dati a caso che ti metto il codice.

ghisirds
09-07-2007, 22.54.47
mi hanno già suggerito così, grazie.

In B8:
=SOMMA(LUNGHEZZA($A$7:B7))+RIF.COLONNA(A7)-1
inserisci con ctrl+maiusc+invio
e ricopi a destra

in B9:
=B7

In C9:
=B9&" "&C7
e ricopi a destra

In B13:
=INDICE($B$9:$E$9;CONFRONTA(A13;$B$8:$E$8))
e ricopi a destra

Alexsandra
09-07-2007, 23.05.03
ho visto
http://img521.imageshack.us/img521/2613/crosspointnl6.th.jpg (http://img521.imageshack.us/my.php?image=crosspointnl6.jpg)

Hai riempito tutti i forum :timid: