PDA

Visualizza versione completa : Exel "formula per cancellare i doppi"


musicboy
05-10-2001, 09.14.48
Ciao,
io ho un file con 3000 righe, purtroppo su questo file ci sono delle righe doppie, ma devo stare attento, la riga può essere uguale quasi tutta, magari cambia solo una cella.
Io dovrei appunto eliminare la doppia, e su 3000 righe farlo a mano piuttosto cambio lavoro.

Ciao

ale_pelly
05-10-2001, 11.11.44
ipotesi di soluzione

1) per ogni riga, concatena tutte le celle in modo da ottenere su una colonna nuova un'unica stringa di testo equivalente al contenuto di tutte le colonne precedenti. Puoi farlo con "&" oppure con la funz. "CONCATENA"

2) usa la funzione "CONTA.SE" per rilevare nelle 3000 stringhe di testo ce ne sono 2 o più ripetute.

3) per ogni riga in cui la funzione CONTA.SE restituisce 1 sei sicuro che la stringa è unica; viceversa la stringa ha almeno un doppione!

4) se i doppioni sono pochi puoi eliminare manualmente le righe superflue, viceversa puoi fare un filtro sui valori del CONTA.SE per poi fare un copia-incolla su un nuovo file delle sole righe in cui CONTA.SE=1.

Spero di essere stato chiaro.

Ciao

musicboy
05-10-2001, 11.31.18
Non è così semplice, mi spiego.
Io devo cancellare le righe intere quando all'interno risultano = i dati delle colonne clienti e codice articolo.
Ma se nella colonna clienti ci sono 2 righe uguali e il codoce art. non è =, non dovranno essere cancellate.
ciao

ale_pelly
05-10-2001, 11.43.26
Beh... non cambia la sostanza di quello che ti ho detto.
Al punto 1) anzichè concatenare tutte le colonne, concatena solo "cliente" e "codice articolo", il resto della procedura non cambia.

musicboy
05-10-2001, 13.15.04
Scusa, ma dopo aver cocatenato le due colonne, non capisco bene cosa devo fare, e come ultima cosa, quando ho trovato le doppie, 1 vorrei che si cancellassero da sole, e poi come divide le due colonne concatenate?

ciao

ale_pelly
05-10-2001, 13.34.26
non credo esista un comando che elimina automaticamente le righe doppie

Premesso ciò mi spiego meglio

ammettiamo che la tua tabella sia da A1:K3000 (ad esempio)

ammettiamo che "cliente" sia la colonna B e "codice prodotto" la colonna" C

scegli una colonna ausiliaria (ad es. la L) e scrivi "=B1&C1" tirando questa formula fino alla riga 3000

scegli un'altra colonna ausiliaria (ad es. la M) e scrivi "=CONTA.SE($L$1:$L$3000;"="&L1) e tira questa formula fino alla riga 3000

nella colonna M, a questo punto, saranno comparsi dei numeri che indicano quante volte ogni stringa della colonna L è ripetuta (almeno una!!)

seleziona TUTTA la tabella (anche le colonne ausiliarie che hai creato)

fai Dati-->Filtro-->Filtro Automatico

apri il filtro sulla colonna ausiliaria M e scegli di filtrare tutte le righe uguali a 1. Così facendo noterai che alcune righe (quelle dopie!) verranno nascoste

Riseleziona di nuovo la tabella (stavolta puoi lasciare fuori le due colonne ausiliarie!) e incollala in un'altro foglio


FINEEEE.

Ti assicuro che è molto più lunga a dire che a fare