PDA

Visualizza versione completa : virus Oleadm.b


Lionsquid
11-07-2005, 09.55.22
questo virus, Oleadm.b l'ho incontrato per la prima volta ieri pomeriggio...

documentandomi presso il Sarc della Symantec e altri siti AV, ho scaricato la procedura di rimozione...

questa simpatica bestiola infetta il wininet.dll, che non sono riuscito a pulire/eliminare con i tools standard, nemmeno usando lo scangui in mod. provvisoria in quanto il file Ŕ bloccato....

seguita alla lettera, la procedura di rimozione, il virus si debella, eccetto la wininet.dll, che ho rimpiazzato da console

sorpresa...

sostituendo la dll con quella originale (prelevata dalla cartella dllcache) (ho anche provato a sostituirla con una prelevata da un pc con lo stesso SO e stesso grado di aggiornamento)... succede un bel casino..

moltissime applicazioni non partono... il firewall (sygate) non si carica, il RAS non funziona per errore alla configurazione...

l'errore mostrato ricorsivamente Ŕ questo: (vado a memoria :S)

Impossibile trovare il punto di ingresso SHRegGetValueW nella procedura della libreria dinamica SHLWAPI.DLL

ho provato a sostituire, sempre da console (BartPE), anche questa dll.. ma il risultato non cambia..

questo virus sembra innocuo, ma i danni lasciati dalla rimozione sono ingenti....

chi altri si Ŕ imbattuto in questo virus o in problemi simili???

la KB MS non mi ha fornito soluzioni... solo situazioni molto diverse dalla mia...

THX, ciao

Lionsquid
13-07-2005, 00.48.25
aggiornamento ...


mi sono dimenticato di dire che ho provato ad usare WINSOCKSXP per ripristinare i parametri del TCP/IP, dato che non solo non funziona l'adsl, ma nemmeno si riesce ad accedere alle proprietÓ della connessione di rete.....nulla completamente... nesssun men¨ nelle connesioni di rete...

ovviamente ha avuto esito negativo....

altro check Ŕ stato quello di accedere ai criteri di protezione locali... nella speranza di trovare le configurazioni alterate e quindi ripristinarle...

bene, anche qui ho trovato un'ostacolo (apparentemente insormontabile, ma non ho indagato a fondo perchŔ il tempo stringeva e la macchina doveva tornare operativa entro sera)...

mi segnala errori su diversi CLSID.. 3 per la precisione , 2 puntano alla certmgr.dll e il terzo a ipsecsnp.dll

verificate entrambi... sono OK


mi resta il cruccio di non aver potuto tentare SFC /scannow...


ma sono certo che lo reincotrer˛ :D

Giorgius
13-07-2005, 08.16.34
Scarica Spysweeper Trial, lo aggiorni, poi chiudi l'eventuale connessione Internet-Lan e avvii il programma.

Al termine della probabile rimozione dei files sospetti, disintalli lo Spysweeper.

Usa anche con il comando del Dos virtuale la stringa:


"Ipconfig /Flushdns"

Lionsquid
13-07-2005, 08.44.54
Originariamente inviato da Giorgius
Scarica Spysweeper Trial, lo aggiorni, poi chiudi l'eventuale connessione Internet-Lan e avvii il programma.

Al termine della probabile rimozione dei files sospetti, disintalli lo Spysweeper.

Usa anche con il comando del Dos virtuale la stringa:


"Ipconfig /Flushdns"

se non erro il comando Ipconfig /flushdns Ŕ contenuto nel set di istruzioni del Winsocksfix xp....

cmq, il problema Ŕ ben + a monte, dato che non potevo intervenire sulle proprietÓ delle connessioni di rete... in pratica ero tagliato fuori da qualsiasi intervento diretto

lo spysweeper... l'ho mollato mesi fÓ, quando pensavo di scrivere un'articolo.... poi l'ho trovato troppo pesante ed invasivo, anche disinstallato, bisogna dare una passatina a "mano"...

prover˛ cmq, metto l'ultima versione nel USB Pen drive ;)

Thx