PDA

Visualizza versione completa : IF su range di dati.


simon79vi
16-10-2003, 10.16.58
Devo fare un test su delle ore, vale a dire, ho una colonna in cui ho degli orari.

Devo fare in modo che se la mia ora è compresa tra un ora e un'altra nella colonna affianco esca una determinata ora.

Esempio:
Se l'ora è compresa tra 8.20 e 8.30 deve uscire 8.30
A1 = 8.20 B1 sarà uguale a 8.30
B1 = 8.10 B2 sarà uguale a 8.10
Chi mi da qualche suggerimento?

ale_pelly
16-10-2003, 12.13.36
dunque... se è come ho capito io vuoi che:

- se l'ora è compresa tra i due estremi la formula deve restituire l'estremo superiore

- se l'ora non è inclusa tra i due estremi la formula deve solo restituire l'ora senza modificarla

se MIN e MAX sono le celle contenenti i due estremi allora puoi scrivere:

=SE(E(A1>=MIN;A1<=MAX);MAX;A1)

spero di aver capito bene

simon79vi
16-10-2003, 12.20.38
Bravo. Esatto funziona.
Ma che significa quella "E".. che se poi la tolgo non funziona?

Grazie

ale_pelly
16-10-2003, 12.23.18
quella "E" implementa l'AND logico. In pratica restituisce il valore logico VERO se e solo se tutte le condizioni immesse sono vere.

Se lo togli la formula non funziona perchè non testa più la condizione che l'ora sia compresa o no nell'intervello prefissato

ciao

papillon
16-10-2003, 12.34.31
Intendi che se l'orario non rientra nell'intervallo 8.20-8.30 deve scrivere sempre 8.10?Allora, fai così:
in una cella , es. E1 metti l'orario 8.19
in F1 metti 8.31 , in H1 metti 8.30 e in I1 metti 8.10
A questo punto in B1 scrivi: =Se(e(A1>E$1;A1<F$1);H$1;I$1)
Copia la formula in basso fin dove hai i dati nella colonna A.
Se ora provi a inserire un orario nella colonna A, avrai nella colonna B il risultato voluto, ciao e fammi sapere.

simon79vi
16-10-2003, 13.22.28
E se avessi più orari, vale a dire se compreso tra 8.20e8.30 metto 8.30, se compreso tra 10.20e10.30 metto 10.30.

Sarà possibile?

papillon
16-10-2003, 14.09.20
Certo, con un altro Se nidificato.
In pratica, se prendi la formula di ale_pelly, prima di A1), quindi verso la fine, ripeti la formula inserendo nei valori MIN e MAX i nuovi valori, ricordati poi di chiudere cun un'altra parentesi tonda,
ciao.

simon79vi
16-10-2003, 14.17.20
GRANDE ESCE UNA MEGA IF MA FUNZIONA..
GRAZIE.

simon79vi
28-10-2003, 14.49.38
Ho fatto una piccola modifica alla if nidificata, ed ora non so più come uscirne.
Il test di dovrebbe comportare così


=SE(E(A1>=MINa;A1<=MAXa;C1>=MINa;C1<=MAXa);A1;MAXa)
Questa funziona, io però non devo testare solo quel MIN e MAX ma anche altri.
Quindi dovrei ottenere una cosa tipo

=SE(E(A1>=MINa;A1<=MAXa;C1>=MINa;C1<=MAXa);A1;MAXa)SE(E(A1>=MINb;A1<=MAXb;C1>=MINb;C1<=MAXb);A1;MAXb)

Ma così non va.

Funziona solo se la metto così:
=SE(E(A1>=MINa;A1<=MAXa;C1>=MINa;C1<=MAXa);A1;SE(E(A1>=MINb;A1<=MAXb;C1>=MINb;C1<=MAXb);A1;MAXa) --> oppure Maxb
Ma così non è corretto perchè il valore butta fuori quando calcola la seconda If non è corretto.
Chi mi aiuta?

ale_pelly
28-10-2003, 15.33.14
la seconda formula non ti funziona per il semplice fatto che la sintassi è errata (non puoi unire due SE in quel modo!).

Se ho ben capito devi testare la stessa condizione su più minimi e su più massimi. In questo caso la formula di partenza che hai scritto va ancora bene salvo il fatto che dovresti impostare MINa come massimo di tutti i minimi e MAXa come minimo di tutti i massimi (scusa il gioco di parole!).

In parole povere se hai due coppie minimi-massimi:

MINa,MAXa e MINb,MAXb allora dovresti scrivere:

=SE(E(A1>=max(MINa;MINb);A1<=min(MAXa;MAXb);C1>=max(MINa;MINb);C1<=min(MAXa;MAXb));A1;min(MAXa;MAXb))

in questo modo TUTTI i minimi e TUTTI i massimi sono contemporaneamente soddisfatti.


(minchia che casino!)

ciao

simon79vi
28-10-2003, 15.51.01
gRAZIE

Ma a te funziona?

ale_pelly
28-10-2003, 16.37.55
Non lo so. Sono andato a intuito.

Se mi mandi un file di esempio te lo dico

simon79vi
28-10-2003, 16.41.32
ti ho mandato il file.
ciao

simon79vi
28-10-2003, 16.43.07
mi serve la tua mail xò.

Grazie

ale_pelly
28-10-2003, 16.44.45
dalapl@dalmine.it

comunque potevi allegare il file al thread

simon79vi
29-10-2003, 09.58.22
News?

ale_pelly
29-10-2003, 12.05.08
Ti ho scritto. sentiamoci per mail d'ora in poi se non ti dispiace